config-tizen-ivi, weston: remove users from "input" group, suid root
authorPatrick Ohly <patrick.ohly@intel.com>
Tue, 3 Feb 2015 20:02:28 +0000 (12:02 -0800)
committerPatrick Ohly <patrick.ohly@intel.com>
Wed, 4 Feb 2015 12:10:58 +0000 (04:10 -0800)
It turns out that the suid root bit is needed for weston-launch after
all. It was also set in "Tizen on Yocto" builds published on the
Wiki, but it remains unclear how that was achieved.

The bit was missing because spec2yocto does not translate the permission part
of the file list in the .spec file. We need to add that back manually.

meta-tizen-common-base/recipes-graphics/weston/weston-extraconf.inc
meta-tizen-ivi/recipes-image/config-tizen-profiles/config-tizen-ivi.bb

index b95560f..c77985c 100644 (file)
@@ -15,6 +15,16 @@ do_configure_prepend() {
 pkg_preinst_${PN}() {
 }
 
+do_install_append() {
+    # Done in the .spec file via permissions in the file list.
+    chmod u+s ${D}${bindir}/weston-launch
+
+    # Not done in Tizen, but perhaps it should be? Don't do it here either for now.
+    # When we do it, we also need to move the GROUPADD_PARAM from  config-tizen-ivi.bb
+    # into this recipe here.
+    # chgrp weston-launcher ${D}${bindir}/weston-launch
+}
+
 export libexecdir="${prefix}/libexec"
 
 FILES_${PN} += "${prefix}/lib/weston/cms-static.so"
index 7c07bb2..aee61da 100644 (file)
@@ -39,8 +39,8 @@ GROUPADD_PARAM_${PN} += "; --system -g 6026 db_wrt "
 
 
 
-USERADD_PARAM_${PN} += "   -u 116 -d /home/genivi -m -g users -G users,tty,audio,video,input,weston-launch -r -s /bin/sh genivi  "
-USERADD_PARAM_${PN} += ";  -u 5000 -d /home/app    -m -g users -G users,tty,audio,video,input,weston-launch -r -s /bin/sh app  "
+USERADD_PARAM_${PN} += "   -u 116 -d /home/genivi -m -g users -G users,tty,audio,video,weston-launch -r -s /bin/sh genivi  "
+USERADD_PARAM_${PN} += ";  -u 5000 -d /home/app    -m -g users -G users,tty,audio,video,weston-launch -r -s /bin/sh app  "
 USERADD_PARAM_${PN} += ";          -d /usr/apps -m -g root  --system  -s /bin/false tizenglobalapp "
 
-USERADD_PARAM_${PN} += "; -u 9999 -g users -d /home/guest -m -g users -G users,tty,audio,video,input,weston-launch -r -s /bin/bash guest"
+USERADD_PARAM_${PN} += "; -u 9999 -g users -d /home/guest -m -g users -G users,tty,audio,video,weston-launch -r -s /bin/bash guest"