pkgmgr: do not use absolute path for msgfmt 12/43612/1
authorThiago Santos <thiagoss@osg.samsung.com>
Tue, 23 Jun 2015 00:29:49 +0000 (21:29 -0300)
committerMauro Carvalho Chehab <mchehab@osg.samsung.com>
Fri, 10 Jul 2015 17:34:13 +0000 (14:34 -0300)
Let it use the $PATH variable instead.

Change-Id: Ie2b2060544ac8fc581508a75c43cdeaa49b0bde8
Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
Reviewed-By: Derek Foreman <derekf@osg.samsung.com>
meta-tizen-common-base/recipes-application-framework/pkgmgr/files/0001-pkgmgr-do-not-set-an-absolute-path-to-msgfmt.patch [new file with mode: 0644]
meta-tizen-common-base/recipes-application-framework/pkgmgr/pkgmgr-extraconf.inc

diff --git a/meta-tizen-common-base/recipes-application-framework/pkgmgr/files/0001-pkgmgr-do-not-set-an-absolute-path-to-msgfmt.patch b/meta-tizen-common-base/recipes-application-framework/pkgmgr/files/0001-pkgmgr-do-not-set-an-absolute-path-to-msgfmt.patch
new file mode 100644 (file)
index 0000000..ff1b4c2
--- /dev/null
@@ -0,0 +1,25 @@
+From 26b485036d8a4b9261f8da5677ceab87b654448e Mon Sep 17 00:00:00 2001
+From: Thiago Santos <thiagoss@osg.samsung.com>
+Date: Mon, 22 Jun 2015 21:27:02 -0300
+Subject: [PATCH] pkgmgr: do not set an absolute path to msgfmt
+
+---
+ server/po/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/server/po/CMakeLists.txt b/server/po/CMakeLists.txt
+index e3aebb4..340f706 100644
+--- a/server/po/CMakeLists.txt
++++ b/server/po/CMakeLists.txt
+@@ -2,7 +2,7 @@
+ SET(POFILES en_US.po en_GB.po ja_JP.po ko_KR.po zh_CN.po)
+-SET(MSGFMT "/usr/bin/msgfmt")
++SET(MSGFMT "msgfmt")
+ FOREACH(pofile ${POFILES})
+       SET(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${pofile})
+-- 
+2.1.4
+
index 3bbd50e..06fcabe 100644 (file)
@@ -1,4 +1,5 @@
 SRC_URI += "file://Add_extralib.diff"
+SRC_URI += "file://0001-pkgmgr-do-not-set-an-absolute-path-to-msgfmt.patch"
 SRC_URI_append_class-native = " file://remove-dlog-for-native-build.patch"
 
 do_compile_prepend_class-native() {