Description:Adding the v4l2grab utility and wpa_cli package. 76/55276/2
authorwchang kim <wchang.kim@samsung.com>
Tue, 22 Dec 2015 22:57:19 +0000 (07:57 +0900)
committerwchang kim <wchang.kim@samsung.com>
Wed, 23 Dec 2015 08:31:51 +0000 (17:31 +0900)
The recipe of v42lgrab is from 'https://github.com/alext-mkrs/meta-alext-edison/tree/master/recipes-addfeatures'.
This utility is used to take a picture via usb camera supported v4l2.
wpa_cli is added to tizen micro image.
nodejs-npm, openssh-sftp-server and userland are removed from tizen micro image.

Change-Id: Ibe109b4f57809abdd637240916295f604f077498
Signed-off-by: wchang kim <wchang.kim@samsung.com>
meta-tizen-micro/recipes-image/raspberrypi2/rpi-hwup-image-tizen-micro.bb
meta-tizen-micro/recipes-multimedia/v4l2grab/README.md [new file with mode: 0755]
meta-tizen-micro/recipes-multimedia/v4l2grab/v4l2grab_git.bb [new file with mode: 0755]

index 6f130aa..004ec78 100755 (executable)
@@ -1,13 +1,12 @@
 # Base this image on rpi-hwup-image
-include recipes-core/images/rpi-hwup-image.bb  
+include recipes-core/images/rpi-hwup-image.bb
 
 CORE_IMAGE_EXTRA_INSTALL += "nodejs"
-CORE_IMAGE_EXTRA_INSTALL += "nodejs-npm"
 CORE_IMAGE_EXTRA_INSTALL += "nginx"
-CORE_IMAGE_EXTRA_INSTALL += "wpa-supplicant"   
-CORE_IMAGE_EXTRA_INSTALL += "openssh openssh-sftp-server"      
-CORE_IMAGE_EXTRA_INSTALL += "systemd-serialgetty util-linux-agetty procps"     
-CORE_IMAGE_EXTRA_INSTALL += "userland"
+CORE_IMAGE_EXTRA_INSTALL += "wpa-supplicant wpa-supplicant-cli"
+CORE_IMAGE_EXTRA_INSTALL += "openssh"
+CORE_IMAGE_EXTRA_INSTALL += "systemd-serialgetty util-linux-agetty procps"
+CORE_IMAGE_EXTRA_INSTALL += "v4l2grab"
 
 # Set root password to "root"
 ROOTFS_POSTPROCESS_COMMAND += "set_root_passwd;"
diff --git a/meta-tizen-micro/recipes-multimedia/v4l2grab/README.md b/meta-tizen-micro/recipes-multimedia/v4l2grab/README.md
new file mode 100755 (executable)
index 0000000..9b97f0b
--- /dev/null
@@ -0,0 +1 @@
+This recipe builds a package for v4l2grab utility
diff --git a/meta-tizen-micro/recipes-multimedia/v4l2grab/v4l2grab_git.bb b/meta-tizen-micro/recipes-multimedia/v4l2grab/v4l2grab_git.bb
new file mode 100755 (executable)
index 0000000..5470527
--- /dev/null
@@ -0,0 +1,20 @@
+DESCRIPTION = "Small command line utility for grabbing JPEGs form V4L2 devices (e.g. USB webcams)"
+HOMEPAGE = "http://www.twam.info/linux/v4l2grab-grabbing-jpegs-from-v4l2-devices"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=1a689deca649cde4b83b2327802f9d68"
+
+# As long as master branch is now beyond the latest tag, let's just use the date
+PV = "20141109"
+PR = "r0"
+
+DEPENDS = "jpeg v4l-utils"
+
+SRC_URI = "git://github.com/twam/v4l2grab.git;protocol=https;branch=master"
+# This is the latest commit as of 09 Nov 2014
+SRCREV = "bb4358911b9581dcf8937962c1355a1c225a2bd7"
+
+S = "${WORKDIR}/git"
+
+inherit autotools gettext
+
+PACKAGES = "${PN} ${PN}-dbg"