Create group weston-launch in profile config 45/27645/1
authorKévin THIERRY <kevin.thierry@open.eurogiciel.org>
Wed, 17 Sep 2014 06:45:06 +0000 (08:45 +0200)
committerKévin THIERRY <kevin.thierry@open.eurogiciel.org>
Wed, 17 Sep 2014 06:45:06 +0000 (08:45 +0200)
Create group weston-launch in config-tizen-common and config-tizen-ivi
recipes instead of weston recipe to prevent the case where user
belonging to the group weston-launch are created before the group is
(which cause an error).

Change-Id: I1ad479bc35ff9bd2aa75782e7e7f7e0a70eb0a7e
Signed-off-by: Kévin THIERRY <kevin.thierry@open.eurogiciel.org>
recipes-image/config-tizen-profiles/config-tizen-common.bb
recipes-image/config-tizen-profiles/config-tizen-ivi.bb
recipes-tizen/weston/weston-extraconf.inc

index 51e8318..d508214 100644 (file)
@@ -8,7 +8,7 @@ inherit allarch useradd
 
 USERADD_PACKAGES = "${PN}"
 
-GROUPADD_PARAM_${PN} = "-g 191 display; -g 100 users; -g 1004 input; -g 190 systemd-journal; -g 54 lock"
+GROUPADD_PARAM_${PN} = "-g 191 display; -g 100 users; -g 1004 input; -g 190 systemd-journal; -g 54 lock; --system -g 192 weston-launch"
 
 USERADD_PARAM_${PN} = "  -d /run/display -m  -u 115  -g display -G users,input,tty,display  -s /bin/sh display; "
 USERADD_PARAM_${PN} += " -d /home/alice -m -u 5001   -g users   -G users,display -r -s /bin/sh alice; "
index 761d0ce..f49f535 100644 (file)
@@ -8,6 +8,6 @@ inherit allarch useradd
 
 USERADD_PACKAGES = "${PN}"
 
-GROUPADD_PARAM_${PN} = "-g 100 users; -g 5000 app; -g 54 lock; -g 190 systemd-journal "
+GROUPADD_PARAM_${PN} = "-g 100 users; -g 5000 app; -g 54 lock; -g 190 systemd-journal; --system -g 192 weston-launch "
 
 USERADD_PARAM_${PN} += " -u 5000 -d /home/app -m -g users -G users,weston-launch -r -s /bin/sh app "
index fcf909e..f74798f 100644 (file)
@@ -1,5 +1,3 @@
-inherit useradd
-
 RDEPENDS_${PN} += "xkeyboard-config"
 RRECOMMENDS_${PN} = "liberation-fonts"
 
@@ -8,9 +6,6 @@ RDEPENDS_${PN}_remove = "weston-startup"
 SRC_URI += "file://make-lcms-explicitly-configurable.patch"
 SRC_URI += "file://make-libwebp-explicitly-configurable.patch"
 
-USERADD_PACKAGES = "${PN}"
-GROUPADD_PARAM_${PN} = "--system -g 192 weston-launch"
-
 EXTRA_OECONF += "   \
                     --enable-wayland-compositor \
                     --disable-vaapi-recorder \