mesa: don't apply Intel fixup patch for non-x86 archs 10/43610/1
authorMauro Carvalho Chehab <mchehab@osg.samsung.com>
Fri, 10 Jul 2015 11:08:10 +0000 (08:08 -0300)
committerMauro Carvalho Chehab <mchehab@osg.samsung.com>
Fri, 10 Jul 2015 17:33:58 +0000 (14:33 -0300)
As the name says, the patch below:
0001-intel-FixinitialMakeCurrentfordrawablesofmultiscreens.patch
is for the Intel DRI drivers. Don't apply it for non-x86
archs, as it doesn't make sense out there.

This bug was discovered by Derek Foreman <derekf@osg.samsung.com>.

Change-Id: I809582a65b6952cd91c648e4fc5606c092a2123f
Signed-off-by: Mauro Carvalho Chehab <mchehab@osg.samsung.com>
Reviewed-By: Derek Foreman <derekf@osg.samsung.com>
meta-tizen-adaptation/meta/recipes-graphics/mesa/mesa_%.bbappend

index f6e0a37..73dc0da 100644 (file)
@@ -1,7 +1,8 @@
 SECTION = "Graphics & UI Framework/Hardware Adaptation"
 
 FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRC_URI += "file://0001-intel-FixinitialMakeCurrentfordrawablesofmultiscreens.patch"
+SRC_URI_append_x86 += "file://0001-intel-FixinitialMakeCurrentfordrawablesofmultiscreens.patch"
+SRC_URI_append_x86-64 += "file://0001-intel-FixinitialMakeCurrentfordrawablesofmultiscreens.patch"
 
 # Enabling gallium-llvm creates a dependency on llvm.
 # meta-openembedded provides that.