remove bashism rev_0.6
authorRonan Le Martret <ronan@fridu.net>
Tue, 2 Dec 2014 14:55:36 +0000 (15:55 +0100)
committerRonan Le Martret <ronan@fridu.net>
Tue, 2 Dec 2014 14:55:36 +0000 (15:55 +0100)
Change-Id: I70ee3ce8a283a2fe5b2e0839caf6e72a5f291323

40 files changed:
meta-tizen-common-base/recipes-application-framework/capi-appfw-package-manager/capi-appfw-package-manager_git.bb
meta-tizen-common-base/recipes-application-framework/pkgmgr-info/pkgmgr-info_git.bb
meta-tizen-common-base/recipes-application-framework/status/status-extraconf.inc
meta-tizen-common-base/recipes-application-framework/status/status.inc
meta-tizen-common-base/recipes-application-framework/status/status_git.bb
meta-tizen-common-base/recipes-applications/libslp-memo/libslp-memo.inc
meta-tizen-common-base/recipes-applications/libslp-memo/libslp-memo_git.bb
meta-tizen-common-base/recipes-connectivity/bluetooth-frwk/bluetooth-frwk.inc
meta-tizen-common-base/recipes-connectivity/bluetooth-frwk/bluetooth-frwk_git.bb
meta-tizen-common-base/recipes-connectivity/bluetooth-tools/bluetooth-tools.inc
meta-tizen-common-base/recipes-connectivity/bluetooth-tools/bluetooth-tools_git.bb
meta-tizen-common-base/recipes-connectivity/nfc-manager-neard/nfc-manager-neard-extraconf.inc
meta-tizen-common-base/recipes-connectivity/nfc-manager-neard/nfc-manager-neard.inc
meta-tizen-common-base/recipes-connectivity/nfc-manager-neard/nfc-manager-neard_git.bb
meta-tizen-common-base/recipes-core/libwbxml2/libwbxml2.inc
meta-tizen-common-base/recipes-core/libwbxml2/libwbxml2_git.bb
meta-tizen-common-base/recipes-extended/festival/festival-extraconf.inc
meta-tizen-common-base/recipes-extended/festival/festival.inc
meta-tizen-common-base/recipes-graphics/weekeyboard/weekeyboard.inc
meta-tizen-common-base/recipes-graphics/weston/weston.inc
meta-tizen-common-base/recipes-multimedia/libmm-log/libmm-log.inc
meta-tizen-common-base/recipes-multimedia/libmm-log/libmm-log_git.bb
meta-tizen-common-base/recipes-multimedia/libmm-utility/libmm-utility-extraconf.inc
meta-tizen-common-base/recipes-multimedia/libmm-utility/libmm-utility.inc
meta-tizen-common-base/recipes-multimedia/libmm-utility/libmm-utility_git.bb
meta-tizen-common-base/recipes-multimedia/pulseaudio/pulseaudio.inc
meta-tizen-common-base/recipes-multimedia/pulseaudio/pulseaudio_git.bb
meta-tizen-common-base/recipes-security/libsecret/libsecret_git.bb
meta-tizen-common-devtools/recipes-devtools/testkit-lite/testkit-lite.inc
meta-tizen-common-devtools/recipes-devtools/testkit-lite/testkit-lite_git.bb
meta-tizen-common-share/recipes-core/murphy/murphy.inc
meta-tizen-common-share/recipes-core/murphy/murphy_git.bb
meta-tizen-common-share/recipes-efl/efl-theme-tizen-hd/efl-theme-tizen-hd.inc
meta-tizen-common-share/recipes-efl/efl-theme-tizen-hd/efl-theme-tizen-hd_git.bb
meta-tizen-ivi/recipes-modello/Modello-AMBSimulator/Modello-AMBSimulator_git.bb
meta-tizen-ivi/recipes-modello/Modello-Appmanager/Modello-Appmanager_git.bb
meta-tizen-ivi/recipes-modello/Modello-Common/Modello-Common_git.bb
meta-tizen-ivi/recipes-modello/Modello-Dashboard/Modello-Dashboard_git.bb
meta-tizen-ivi/recipes-modello/Modello-Hvac/Modello-Hvac_git.bb
meta-tizen-ivi/recipes-modello/phoned/phoned-extraconf.inc

index 1b4f491..2527ab9 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/api/package-manager;tag=f3bb3a3ca795f4c38fbf51a3c6696d342b0cf0eb;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/api/package-manager;tag=16c0f38bfe8b93b54dee0668a87d6164d7342782;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 1cd4e68..4c927d5 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/appfw/pkgmgr-info;tag=608fcd4aaf647da75df552f495d913468d377917;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/appfw/pkgmgr-info;tag=868104fed4766063713eff0184bb9daef30bcfe9;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index a51cf69..7884647 100644 (file)
@@ -7,7 +7,7 @@ do_compile() {
  unset DISPLAY
 
 
- export LDFLAGS+=" -Wl,--rpath=${prefix}/lib -Wl,--as-needed "
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath=${prefix}/lib -Wl,--as-needed "
 
 
    cmake \
index 1944fd1..6156101 100644 (file)
@@ -1,6 +1,6 @@
-DESCRIPTION = "status library"
+DESCRIPTION = "Status library"
 HOMEPAGE = "http://nohomepage.org"
-SECTION = "TBD"
+SECTION = "Applications/Core Applications"
 LICENSE = "Apache-2.0"
 PV = "0.0.1"
 
@@ -32,6 +32,7 @@ DEPENDS = ""
 #DEPENDS of status
 inherit tizen_cmake
 DEPENDS += "dbus"
+DEPENDS += "tizen-platform-config"
 DEPENDS += "aul"
 DEPENDS += "dlog"
 inherit pkgconfig
@@ -59,7 +60,7 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
- export LDFLAGS+="-Wl,--rpath=${prefix}/lib -Wl,--as-needed"
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath=${prefix}/lib -Wl,--as-needed"
  
    cmake \
          -DCMAKE_VERBOSE_MAKEFILE=ON \
@@ -73,7 +74,7 @@ do_compile() {
          -DBUILD_SHARED_LIBS:BOOL=ON \
          -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
          ${EXTRA_OECMAKE} .
- make -j16
oe_runmake -j16
  
  
  
@@ -97,9 +98,8 @@ do_install() {
    rm -f ${D}${infodir}/dir 
    find ${D} -regex ".*\.la$" | xargs rm -f -- 
    find ${D} -regex ".*\.a$" | xargs rm -f --
- mkdir -p ${D}/usr/share/license
- cp -f LICENSE ${D}/usr/share/license/status
+ mkdir -p ${D}${prefix}/share/license
+ cp -f LICENSE ${D}${prefix}/share/license/status
  
  
  
@@ -108,15 +108,16 @@ do_install() {
 pkg_postinst_${PN}() {
     #!/bin/sh -e
 
+    users_gid=$(getent group users | cut -f3 -d':')
     init_vconf()
     {
-        vconftool set -t int memory/private/libstatus/music/state 0 -i -g 5000
-        vconftool set -t int memory/private/libstatus/radio/state 0 -i -g 5000
-        vconftool set -t int memory/private/libstatus/vr/state 0 -i -g 5000
-        vconftool set -t int memory/private/libstatus/music/pid -1 -i -g 5000
-        vconftool set -t int memory/private/libstatus/radio/pid -1 -i -g 5000
-        vconftool set -t int memory/private/libstatus/vr/pid -1 -i -g 5000
-        vconftool set -t string memory/private/libstatus/message "" -i -g 5000
+        vconftool set -t int memory/private/libstatus/music/state 0 -i -g $users_gid
+        vconftool set -t int memory/private/libstatus/radio/state 0 -i -g $users_gid
+        vconftool set -t int memory/private/libstatus/vr/state 0 -i -g $users_gid
+        vconftool set -t int memory/private/libstatus/music/pid -1 -i -g $users_gid
+        vconftool set -t int memory/private/libstatus/radio/pid -1 -i -g $users_gid
+        vconftool set -t int memory/private/libstatus/vr/pid -1 -i -g $users_gid
+        vconftool set -t string memory/private/libstatus/message "" -i -g $users_gid
     }
     [ "x$D" == "x" ] && ldconfig
     init_vconf
@@ -135,7 +136,7 @@ PACKAGES += " status-dev "
 
 status_files = ""
 status_files += "${prefix}/lib/*.so*"
-status_files += "/usr/share/license/status"
+status_files += "${prefix}/share/license/status"
 MANIFESTFILES_${PN} = "status.manifest"
 
 status-dev_files = ""
index 7d50fd7..53b5ee3 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/appfw/status;tag=2afa6a6447a70d20f63c67d5ae59cf26608146d9;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/appfw/status;tag=bebaf1fd70a6b15dbb428f223e75811a83ece711;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 0a400d0..1e59861 100644 (file)
@@ -58,7 +58,7 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
- export LDFLAGS+=" -Wl,--rpath=${prefix}/lib -Wl,--as-needed -Wl,--hash-style=both"
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath=${prefix}/lib -Wl,--as-needed -Wl,--hash-style=both"
  
    cmake \
          -DCMAKE_VERBOSE_MAKEFILE=ON \
index 075a649..ae58490 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/apps/core/preloaded/libslp-memo;tag=5b9cfdc3280cb1aeb694a0fcfadd0c8512492187;nobranch=1"
+SRC_URI += "git://review.tizen.org/apps/core/preloaded/libslp-memo;tag=2d7a05e35636d8a379f4f2eaac3b180c51e18592;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index afa93bc..596cec5 100644 (file)
@@ -89,8 +89,8 @@ do_compile() {
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
  
- export CFLAGS+="   -Wall -g -fvisibility=hidden -fPIC"
- export LDFLAGS+=" -Wl,--rpath=${prefix}/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
+ export CFLAGS="${CFLAGS}   -Wall -g -fvisibility=hidden -fPIC"
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath=${prefix}/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs"
  
  
    cmake \
@@ -110,7 +110,7 @@ do_compile() {
   -DLIBNOTIFY_SUPPORT=Off \
   -DLIBNOTIFICATION_SUPPORT=On
  
- make
oe_runmake
  
  
  
@@ -158,6 +158,12 @@ pkg_postinst_${PN}() {
     vconftool set -tf string memory/bluetooth/sco_headset_name "" -g 6520 -i
     vconftool set -tf int memory/bluetooth/device "0" -g 6520 -i
     vconftool set -tf int memory/bluetooth/btsco "0" -g 6520 -i
+    # set 'User' smack label to vconf keys in order to allow bt-service to access them.
+    chsmack -a 'User' $D${prefix}/kdb/db/bluetooth/status
+    chsmack -a 'User' $D${prefix}/kdb/file/private/bt-service/flight_mode_deactivated
+    chsmack -a 'User' $D${prefix}/kdb/memory_init/memory/bluetooth/sco_headset_name
+    chsmack -a 'User' $D${prefix}/kdb/memory_init/memory/bluetooth/device
+    chsmack -a 'User' $D${prefix}/kdb/memory_init/memory/bluetooth/btsco
 
 }
 
index 08b0c6a..d2c0724 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/connectivity/bluetooth-frwk;tag=26ef41a381278d8f0e609218ae458d8802c3c906;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/connectivity/bluetooth-frwk;tag=903f4abdc198a6360e7f02a8cc6b876a2f463d2a;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index ee6261f..8318f04 100644 (file)
@@ -54,8 +54,8 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
- export CFLAGS+=" -fpie -fvisibility=hidden"
- export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
+ export CFLAGS="${CFLAGS} -fpie -fvisibility=hidden"
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
  
  
    cmake \
@@ -70,7 +70,7 @@ do_compile() {
          -DBUILD_SHARED_LIBS:BOOL=ON \
          -DCMAKE_TOOLCHAIN_FILE=${WORKDIR}/toolchain.cmake \
          ${EXTRA_OECMAKE} . -DCMAKE_INSTALL_PREFIX=${prefix}
- make -j16
oe_runmake -j16
  
  
  
index fa906ab..eb063ca 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/connectivity/bluetooth-tools;tag=c5406a3be5315fb8ec0ecfff0b0a47f53c4af046;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/connectivity/bluetooth-tools;tag=ecb6831625572976a78a5ebdbe32fa0c0dfdb45e;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 9f3fc55..8b79f3a 100644 (file)
@@ -1,7 +1,7 @@
 DESCRIPTION = "NFC framework manager"
 HOMEPAGE = "http://nohomepage.org"
 SECTION = "Network & Connectivity/NFC"
-LICENSE = "Flora"
+LICENSE = "Apache-2.0"
 PV = "0.1.6"
 
 SRC_URI = ""
@@ -45,6 +45,7 @@ DEPENDS = ""
 DEPENDS += "pkgmgr"
 DEPENDS += "security-server"
 DEPENDS += "aul"
+DEPENDS += "capi-network-bluetooth"
 DEPENDS += "dlog"
 DEPENDS += "curl"
 inherit tizen_cmake
@@ -54,7 +55,6 @@ inherit pkgconfig
 DEPENDS += "capi-media-wav-player"
 DEPENDS += "glib-2.0"
 DEPENDS += "system-server"
-DEPENDS += "bluetooth-frwk"
 inherit pythonnative
 DEPENDS += "libsvi"
 DEPENDS += "tizen-platform-config"
@@ -76,7 +76,6 @@ do_prep() {
  cp ${S}/packaging/nfc-manager-neard.manifest .
  
  
 }
 do_patch_append() {
     bb.build.exec_func('do_prep', d)
index caf1fa1..4e8c07a 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/connectivity/nfc-manager-neard;tag=2d1f3df127d3b84ebf9d1cdc0d95e69e920933b1;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/connectivity/nfc-manager-neard;tag=45f2831a6d738c5df32b065c6853636fea85f42a;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index bd6c85f..04a8fb6 100644 (file)
@@ -67,10 +67,9 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
- BUILD_SRC=$(pwd)
- mkdir -p build
- pushd build
+ mkdir build
+ CURDIR=$(pwd)
+ cd build
  CFLAGS="$CFLAGS" \
  CXXFLAGS="$CFLAGS" \
  
@@ -88,9 +87,9 @@ do_compile() {
          ${EXTRA_OECMAKE} \
          -DCMAKE_BUILD_TYPE=None \
          -DENABLE_INSTALL_DOC:BOOL=OFF \
-         ${BUILD_SRC}
oe_runmake -j16 VERBOSE=1
- popd
+          ${WORKDIR}/libwbxml-0.11.2
+ make -j16 VERBOSE=1
+ cd ${CURDIR}
  
  
  
@@ -105,7 +104,8 @@ do_install() {
  rm -rf ${D}
  mkdir -p ${D}
  
- pushd build
+ CURDIR=$(pwd)
+ cd build
  
    oe_runmake \
          DESTDIR=${D} \
@@ -115,7 +115,7 @@ do_install() {
    rm -f ${D}${infodir}/dir 
    find ${D} -regex ".*\.la$" | xargs rm -f -- 
    find ${D} -regex ".*\.a$" | xargs rm -f --
- popd
+ cd ${CURDIR}
  
  
 }
index d9ea953..a3f312b 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/upstream/libwbxml2;tag=717cf1e3430cacd4c0ba04394b8f60f1e4ad4900;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/upstream/libwbxml2;tag=e7ff0d80b8638cd60e06be6d8a3c9364b617ffb1;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 77bbdbd..77222ef 100644 (file)
@@ -5,9 +5,10 @@ SRC_URI += "file://remove_doc.patch"
 INSANE_SKIP_${PN} = "dev-deps"
 
 do_prep_prepend() {
- pushd ${S}/../
+ CIRDIR=$(pwd)
+ cd ${S}/../
  ln -sf ${S} ${PN}-${PV}
- popd
+ cd ${CIRDIR}
 }
 
 do_install_prepend() {
index 66f24b0..44f898d 100644 (file)
@@ -33,21 +33,25 @@ inherit pkgconfig
 do_prep() {
  cd ${S}
  #extracte source 1
- pushd ${S}/../
+ CURDIR=$(pwd)
+ cd ${S}/../
  tar -zxf ${S}/packaging/speech_tools-2.1-release.tar.gz
- popd
+ cd ${CURDIR}
  #extracte source 2
- pushd ${S}/../
+ CURDIR=$(pwd)
+ cd ${S}/../
  tar -zxf ${S}/packaging/festlex_CMU.tar.gz
- popd
+ cd ${CURDIR}
  #extracte source 3
- pushd ${S}/../
+ CURDIR=$(pwd)
+ cd ${S}/../
  tar -zxf ${S}/packaging/festvox_kallpc16k.tar.gz
- popd
+ cd ${CURDIR}
  #extracte source 4
- pushd ${S}/../
+ CURDIR=$(pwd)
+ cd ${S}/../
  tar -zxf ${S}/packaging/festlex_POSLEX.tar.gz
- popd
+ cd ${CURDIR}
  chmod -Rf a+rX,u+w,g-w,o-w ${S}
  #setup -q -b 1 -b 2 -b 3 -b 4
  mv ../festival/lib/* lib/
index 43f7c55..8ad9195 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Virtual Keyboard Application"
 HOMEPAGE = "http://github.com/etrunko/weekeyboard"
 SECTION = "Graphics & UI Framework/Libraries"
 LICENSE = "Apache-2.0"
-PV = "0.0.2"
+PV = "0.0.3"
 
 SRC_URI = ""
 
@@ -65,7 +65,7 @@ do_compile() {
   
   
 }
-EXTRA_OECONF += " --disable-ibus"
+EXTRA_OECONF += ""
 
 do_install() {
  export RPM_BUILD_ROOT=${D}
@@ -95,6 +95,7 @@ PACKAGES += " weekeyboard "
 weekeyboard_files = ""
 weekeyboard_files += "${prefix}/bin/weekeyboard"
 weekeyboard_files += "${prefix}/share/weekeyboard/*.edj"
+weekeyboard_files += "${prefix}/share/X11/xkb/symbols/wkb"
 MANIFESTFILES_${PN} = "weekeyboard.manifest"
 
 FILES_${PN} = "${weekeyboard_files}"
index a59358a..6e4a5a7 100644 (file)
@@ -141,6 +141,8 @@ do_install() {
  install -m 755 weston-fullscreen ${D}${prefix}/bin
  
  
+ install -d ${D}${prefix}/lib/systemd/user
+ install -m 644 ${S}/packaging/weston.target ${D}${prefix}/lib/systemd/user/weston.target
  # The weston.service unit file must be provided by the weston-startup
  # virtual package, i.e. "Provide: weston-startup".  The weston-startup
  # virtual package requirement is intended to force Tizen profile
@@ -181,6 +183,7 @@ weston_files += "${prefix}/lib/weston/headless-backend.so"
 weston_files += "${prefix}/lib/weston/wayland-backend.so"
 weston_files += "${prefix}/lib/weston/gl-renderer.so"
 weston_files += "${prefix}/share/weston"
+weston_files += "${prefix}/lib/systemd/user/weston.target"
 MANIFESTFILES_${PN} = "weston.manifest"
 
 weston-clients_files = ""
index c074e6b..8cbf6ab 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "Multimedia Framework LOG Lib"
 HOMEPAGE = "http://nohomepage.org"
-SECTION = "Multimedia/Media Service"
+SECTION = "Multimedia/Multimedia Framework"
 LICENSE = "Apache-2.0"
 PV = "0.1.5"
 
@@ -49,7 +49,7 @@ do_compile() {
   unset DISPLAY
   LD_AS_NEEDED=1; export LD_AS_NEEDED ;
   
-  export CFLAGS+=" -DUSE_DLOG"
+  CFLAGS="$CFLAGS -DUSE_DLOG"; export CFLAGS
   ./autogen.sh
   
   autotools_do_configure
index 098edd3..467d79e 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/multimedia/libmm-log;tag=4b994c87d76bafd03b02833a5645c524487f914a;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/multimedia/libmm-log;tag=9e5e5b23416d9a169c587a25a7653fa884444f74;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 24d47be..1556c60 100644 (file)
@@ -8,8 +8,8 @@ do_compile() {
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
 
 
- CFLAGS="$CFLAGS -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" -D_MM_PROJECT_FLOATER" \
- LDFLAGS+=" -Wl,--rpath=${prefix}/lib -Wl,--hash-style=both -Wl,--as-needed " \
+ CFLAGS="$CFLAGS -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" -D_MM_PROJECT_FLOATER" 
+ LDFLAGS="${LDFLAGS} -Wl,--rpath=${prefix}/lib -Wl,--hash-style=both -Wl,--as-needed " 
 
    autotools_do_configure --build=${TARGET_SYS} --host=${HOST_SYS} \
          --target=x86_64-tizen-linux \
index d71f52a..e4e6403 100644 (file)
@@ -43,6 +43,7 @@ DEPENDS += "libmm-log"
 inherit pkgconfig
 DEPENDS += "glib-2.0"
 DEPENDS += "libmm-ta"
+DEPENDS += "tizen-platform-config"
 
 do_prep() {
  cd ${S}
@@ -66,9 +67,8 @@ do_compile() {
   unset DISPLAY
   LD_AS_NEEDED=1; export LD_AS_NEEDED ;
   
-  ./autogen.sh
-  
-  CFLAGS="$CFLAGS -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" -D_MM_PROJECT_FLOATER"   LDFLAGS+="-Wl,--rpath=${prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"   
+  mkdir -p m4
+  CFLAGS="$CFLAGS -DEXPORT_API=\"__attribute__((visibility(\\\"default\\\")))\" -D_MM_PROJECT_FLOATER"   LDFLAGS="$LDFLAGS -Wl,--rpath=${prefix}/lib -Wl,--hash-style=both -Wl,--as-needed"   
   autotools_do_configure
   oe_runmake -j16
   
index 89e97a0..a41c6ab 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/multimedia/libmm-utility;tag=2478d64176e02c32bdd12ba2ed58a57a4faeada0;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/multimedia/libmm-utility;tag=4295b93e417e4734c90639d20ff6c60b110172d7;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index e731fbb..7767460 100644 (file)
@@ -191,14 +191,15 @@ do_install() {
    find ${D} -regex ".*\.a$" | xargs rm -f --
  #find_lang pulseaudio
  
- pushd ${D}${sysconfdir}/pulse/filter
+ CURDIR=$(pwd)
+ cd ${D}${sysconfdir}/pulse/filter
  ln -sf filter_8000_44100.dat filter_11025_44100.dat
  ln -sf filter_8000_44100.dat filter_12000_44100.dat
  ln -sf filter_8000_44100.dat filter_16000_44100.dat
  ln -sf filter_8000_44100.dat filter_22050_44100.dat
  ln -sf filter_8000_44100.dat filter_24000_44100.dat
  ln -sf filter_8000_44100.dat filter_32000_44100.dat
- popd
+ cd ${CURDIR}
  
  rm -rf  ${D}${sysconfdir}/xdg/autostart/pulseaudio-kde.desktop
  rm -rf  ${D}${prefix}/bin/start-pulseaudio-kde
@@ -246,7 +247,7 @@ pkg_postinst_libpulse() {
 pkg_postinst_${PN}() {
     #!/bin/sh -e
 
-    /usr/sbin/setcap cap_sys_nice+ep /usr/bin/pulseaudio
+    setcap cap_sys_nice+ep /usr/bin/pulseaudio
 
 }
 
@@ -281,7 +282,7 @@ pkg_postrm_${PN}() {
 pkg_postrm_${PN}() {
     #!/bin/sh -e
 
-    /usr/sbin/setcap -r /usr/bin/pulseaudio
+    setcap -r /usr/bin/pulseaudio
     #lang_package
 
 }
index 202c147..e9452d2 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/upstream/pulseaudio;tag=6a1a844dbcb898d381105cd3a5b4c3a32effef3f;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/upstream/pulseaudio;tag=9f3f3d9dfe4449a019945f65002f714aa49dcc2d;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 91ddd54..fdea5b3 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/upstream/libsecret;tag=323fd83e4fa5a23e79e83b210d853705e21bdd81;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/upstream/libsecret;tag=115bcbe47059371f172286c68d730d7c59f9e8fc;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 5e22775..77f192b 100644 (file)
@@ -77,7 +77,7 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
+ #empty
  
  
  
@@ -96,11 +96,12 @@ do_install() {
  install -d ${D}${prefix}/share/testkit-lite
  cp -r xsd ${D}${prefix}/share/testkit-lite
  #fdupes ${D}
- pushd ${D}${prefix}/lib/python2.7/site-packages
+ CURDIR=$(pwd)
+ cd  ${D}${prefix}/lib/python2.7/site-packages
  
  find . -name '*.pyc' -exec rm -f {} \; 
  python -c "import sys, os, compileall; br='${D}'; compileall.compile_dir(sys.argv[1], ddir=br and (sys.argv[1][len(os.path.abspath(br)):]+'/') or None)" . 
- popd
+ cd ${CURDIR}
  
  
  
index fe86121..3aa6020 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/test/tools/testkit-lite;tag=6ebfe1474b3c2db6c052fa3d2f90a1bac25c3ec2;nobranch=1"
+SRC_URI += "git://review.tizen.org/test/tools/testkit-lite;tag=da799487c06614bf07afd6006f2a57520f3f036c;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index cacbb45..ca55441 100644 (file)
@@ -2,7 +2,7 @@ DESCRIPTION = "Resource policy framework"
 HOMEPAGE = "http://nohomepage.org"
 SECTION = "System/Service"
 LICENSE = "BSD-3-Clause"
-PV = "0.0.59"
+PV = "0.0.67"
 
 SRC_URI = ""
 
@@ -249,20 +249,20 @@ do_install() {
  
  # Generate list of linkedin plugins (depends on the configuration).
  outdir="`pwd`"
- pushd ${D} >& /dev/null && \
+ cd ${D} 
  find ./${prefix}/lib -name libmurphy-plugin-*.so* | \
- sed 's#^./*#/#g' > $outdir/filelist.plugins-base && \
- popd >& /dev/null
+ sed 's#^./*#/#g' > $outdir/filelist.plugins-base 
+ cd $(outdir)
  echo "Found the following linked-in plugin files:"
  cat $outdir/filelist.plugins-base | sed 's/^/    /g'
  
  # Generate list of header files, filtering ones that go to subpackages.
  outdir="`pwd`"
- pushd ${D} >& /dev/null && \
+ cd ${D}
  find ./${prefix}/include/murphy | \
  grep -E -v '((pulse)|(ecore)|(glib)|(qt))-glue' | \
- sed 's#^./*#/#g' > $outdir/filelist.devel-includes && \
- popd >& /dev/null
+ sed 's#^./*#/#g' > $outdir/filelist.devel-includes 
+ cd $(outdir)
  
  # Replace the default sample/test config files with the packaging ones.
  rm -f ${D}${sysconfdir}/murphy/*
@@ -279,11 +279,9 @@ do_install() {
  cp packaging.in/murphyd.conf ${D}/usr/lib/tmpfiles.d
  
  # Copy the systemd files in place.
- mkdir -p ${D}${systemd_unitdir}/system
- cp packaging.in/murphyd.service ${D}${systemd_unitdir}/system
- # cp packaging.in/ico-homescreen.service %{buildroot}%{_unitdir_user}
- # cp packaging.in/murphy-wait-for-launchpad-ready.path \
- #     %{buildroot}%{_unitdir_user}
+ #mkdir -p %{buildroot}%{_unitdir}
+ mkdir -p ${D}${prefix}/lib/systemd/user
+ cp packaging.in/murphyd.service ${D}${prefix}/lib/systemd/user
  
  mkdir -p ${D}${sysconfdir}/dbus-1/system.d
  sed "s/@TZ_SYS_USER_GROUP@/users/g" \
@@ -309,7 +307,7 @@ pkg_postinst_${PN}() {
 pkg_postinst_${PN}() {
     #!/bin/sh -e
 
-    /bin/systemctl enable murphyd.service
+    /bin/systemctl --user enable --global murphyd.service
     setcap 'cap_net_admin=+ep' $D${prefix}/bin/murphyd
     ldconfig
 
@@ -346,18 +344,6 @@ pkg_postinst_${PN}() {
 pkg_postinst_${PN}() {
     #!/bin/sh -e
 
-    # prevent system controller from starting
-    # rm -f %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
-    # instead launch just ico-homescreen
-    # rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
-    # ln -s %{_unitdir_user}/murphy-wait-for-launchpad-ready.path \
-    #     %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
-
-}
-
-pkg_postinst_${PN}() {
-    #!/bin/sh -e
-
     ldconfig
 
 }
@@ -372,20 +358,8 @@ pkg_postrm_${PN}() {
 pkg_postrm_${PN}() {
     #!/bin/sh -e
 
-    #if [ "$1" = "0" ]; then
-    # rm -f %{_unitdir_user}/weston.target.wants/murphy-wait-for-launchpad-ready.path
-    # if [ -f %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path ]; then
-    #     ln -sf %{_unitdir_user}/ico-uxf-wait-launchpad-ready.path \
-    #         %{_unitdir_user}/weston.target.wants/ico-uxf-wait-launchpad-ready.path
-    #fi
-
-}
-
-pkg_postrm_${PN}() {
-    #!/bin/sh -e
-
     if [ "$1" = "0" ]; then
-        systemctl disable murphyd.service
+    systemctl --user disable --global murphyd.service
     fi
     ldconfig
 
@@ -507,7 +481,7 @@ murphy-doc_files += "${prefix}/share/doc/murphy/README"
 murphy_files = ""
 murphy_files += "${prefix}/bin/murphyd"
 murphy_files += "${sysconfdir}/murphy"
-murphy_files += "${systemd_unitdir}/system/murphyd.service"
+murphy_files += "${prefix}/lib/systemd/user/murphyd.service"
 murphy_files += "/usr/lib/tmpfiles.d/murphyd.conf"
 murphy_files += "${prefix}/sbin/asm-bridge"
 murphy_files += "${sysconfdir}/dbus-1/system.d"
@@ -536,6 +510,7 @@ murphy-tests_files = ""
 murphy-tests_files += "${prefix}/bin/resource-client"
 murphy-tests_files += "${prefix}/bin/resource-api-test"
 murphy-tests_files += "${prefix}/bin/resource-api-fuzz"
+murphy-tests_files += "${prefix}/bin/resource-context-create"
 murphy-tests_files += "${prefix}/bin/test-domain-controller"
 murphy-tests_files += "${prefix}/bin/murphy-console"
 MANIFESTFILES_${PN}-tests = "murphy.manifest"
index bb45fc1..b769e65 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/murphy;tag=ec834e4a57bf4a9ea63554e2bf3b247b666fe347;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/murphy;tag=b9d006e4db4bc964e5acad83feab71e00d34968d;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index fb20c01..b5894d3 100644 (file)
@@ -49,10 +49,10 @@ do_compile() {
  unset DISPLAY
  LD_AS_NEEDED=1; export LD_AS_NEEDED ;
  
- export CFLAGS+=" --fPIC"
- export LDFLAGS+=" -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=/usr/lib"
+ export CFLAGS="${CFLAGS} --fPIC"
+ export LDFLAGS="${LDFLAGS} -Wl,--hash-style=both -Wl,--as-needed -Wl,--rpath=${prefix}/lib"
  
- make -j16
oe_runmake -j16
  
  
  
@@ -78,9 +78,9 @@ do_install() {
    rm -f ${D}${infodir}/dir 
    find ${D} -regex ".*\.la$" | xargs rm -f -- 
    find ${D} -regex ".*\.a$" | xargs rm -f --
- mkdir -p ${D}/usr/share/license
- cp ${WORKDIR}/git/LICENSE ${D}/usr/share/license/efl-theme-tizen-hd
- cp ${D}/usr/share/elementary/themes/tizen-HD-dark.edj ${D}/usr/share/elementary/themes/tizen-hd.edj
+ mkdir -p ${D}${prefix}/share/license
+ cp ${WORKDIR}/git/LICENSE ${D}${prefix}/share/license/efl-theme-tizen-hd
+ cp ${D}${prefix}/share/elementary/themes/tizen-HD-dark.edj ${D}${prefix}/share/elementary/themes/tizen-hd.edj
  
  
 }
@@ -96,7 +96,7 @@ efl-theme-tizen-hd_files = ""
 efl-theme-tizen-hd_files += "${prefix}/share/elementary/themes/tizen-HD-dark.edj"
 efl-theme-tizen-hd_files += "${prefix}/share/elementary/themes/tizen-HD-light.edj"
 efl-theme-tizen-hd_files += "${prefix}/share/elementary/themes/tizen-hd.edj"
-efl-theme-tizen-hd_files += "/usr/share/license/efl-theme-tizen-hd"
+efl-theme-tizen-hd_files += "${prefix}/share/license/efl-theme-tizen-hd"
 MANIFESTFILES_${PN} = "efl-theme-tizen-hd.manifest"
 
 FILES_efl-theme-tizen-dev = "${efl-theme-tizen-dev_files}"
index c01548f..30e7ac9 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/platform/core/uifw/efl-theme-tizen;tag=3fa1ccde4d2fd7436720accabb70c63deedb87f3;nobranch=1"
+SRC_URI += "git://review.tizen.org/platform/core/uifw/efl-theme-tizen;tag=49873649c3970d5c3cbbd45ef1d141eda696f50d;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 14ed8b7..9afb34d 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/Modello_AMBSimulator;tag=6dcac734d95f99d36b8b5bab9799b3f8860bb176;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/Modello_AMBSimulator;tag=4565c0de0d63e9cbc928a019dcfd9e880de3efc4;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index d8cf10e..bcea137 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Appmanager;tag=29077649bc00e39417d74a1651f94f54a6868a2d;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Appmanager;tag=0e0a81c3107d1e934224a2ccbea4d9ebc069af8d;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 7a33e5d..d55e4eb 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Common;tag=4b00a3518551bc9474ec7009e54b90760cf1faf2;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Common;tag=37655d016e356b40e190768420b6e8d1ab1aab44;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 13a94ba..f7d46e1 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Dashboard;tag=1e8323eff6b8fbf81c9b949978bf0165d1198902;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Dashboard;tag=bd92737dd272e5dc55fdca2fa9ab47f1c03ac0fa;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index 27dba14..0e93304 100644 (file)
@@ -4,7 +4,7 @@ PRIORITY = "10"
 
 LIC_FILES_CHKSUM ??= "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Hvac;tag=af5fbddabc6773cbdd33bf8790808fcec64da485;nobranch=1"
+SRC_URI += "git://review.tizen.org/profile/ivi/Modello_Hvac;tag=f8a0549c2c4efd2c108f0e3941b7edef88714e2b;nobranch=1"
 
 BBCLASSEXTEND += " native "
 
index fca3d89..8f1839a 100644 (file)
@@ -7,7 +7,7 @@ do_compile() {
  
  
  
- export LDFLAGS+=" -Wl,--rpath="${prefix}/lib/wrt-plugins" -Wl,--as-needed "
+ export LDFLAGS="${LDFLAGS} -Wl,--rpath="${prefix}/lib/wrt-plugins" -Wl,--as-needed "
  
    cmake \
          -DCMAKE_VERBOSE_MAKEFILE=ON \