7690205f5c10657631e3189415a42068a2a58f5f
[profile/mobile/platform/kernel/u-boot-tm1.git] / packaging / u-boot-tm1.spec
1 Name: u-boot-sprd
2 Summary: Bootloader for Embedded boards based on ARM processor
3 Version: 2010.12
4 Release: 0
5 Group: System/Kernel
6 License: GPL-2.0+
7 ExclusiveArch: %{arm}
8 URL: http://sourceforge.net/projects/u-boot
9 Source0: %{name}-%{version}.tar.bz2
10 Source1001: packaging/u-boot-tm1.manifest 
11
12 %description
13 bootloader for Embedded boards based on ARM processor
14
15 %package -n u-boot-tm1
16 Summary: A bootloader for Embedded system
17 Group: System/Kernel
18
19 %description -n u-boot-tm1
20 A boot loader for embedded systems.
21 Das U-Boot is a cross-platform bootloader for embedded systems,
22 used as the default boot loader by several board vendors.  It is
23 intended to be easy to port and to debug, and runs on many
24 supported architectures, including PPC, ARM, MIPS, x86, m68k, NIOS,
25 and Microblaze.
26
27 %ifarch %{arm}
28 %global use_mmc_storage 1
29 %endif
30
31 %prep
32 %setup -q
33
34 %build
35 cp %{SOURCE1001} .
36 make distclean
37 make tizen_tm1_config
38
39 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true tools
40
41 %if 1%{?use_mmc_storage}
42 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" CONFIG_ENV_IS_IN_MMC=y env
43 %else
44 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" env
45 %endif
46
47 export PATH="$PATH:tools"
48 make %{?_smp_mflags} EXTRAVERSION=`echo %{vcs} | sed 's/.*u-boot.*#\(.\{9\}\).*/-g\1-TIZEN.org/'`
49
50 # Sign u-boot-multi.bin - output is: u-boot-mmc.bin
51 chmod 755 tools/mkimage_signed.sh
52 mkimage_signed.sh u-boot.bin "tizen_tm1"
53
54 %install
55 rm -rf %{buildroot}
56
57 # u-boot installation
58 mkdir -p %{buildroot}/boot/u-boot
59 install -d %{buildroot}/boot/u-boot
60 install -m 755 u-boot.bin %{buildroot}/boot/u-boot
61 install -m 755 u-boot-mmc.bin %{buildroot}/boot/u-boot
62
63 %clean
64
65 %files -n u-boot-tm1
66 %manifest u-boot-tm1.manifest
67 %defattr(-,root,root,-)
68 /boot/u-boot