tizen 2.4 release
[profile/mobile/platform/kernel/u-boot-tm1.git] / packaging / u-boot-tm1.spec
1 Name: u-boot-sprd
2 Summary: bootloader for Embedded boards based on ARM processor
3 Version: 2010.12
4 Release: 0
5 Group: System Environment/Kernel
6 License: GPL
7 ExclusiveArch: %{arm}
8 URL: http://sourceforge.net/projects/u-boot
9 Source0: %{name}-%{version}.tar.bz2
10 Source1001: packaging/u-boot-tm1.manifest 
11
12 %if "%{tizen_target_name}" != "Z300H"
13 ExcludeArch: %{arm}
14 %endif
15
16 %description
17 bootloader for Embedded boards based on ARM processor
18
19 %package -n u-boot-tm1
20 Summary: A bootloader for Embedded system
21 Group: System Environment/Kernel
22
23 %description -n u-boot-tm1
24 A boot loader for embedded systems.
25 Das U-Boot is a cross-platform bootloader for embedded systems,
26 used as the default boot loader by several board vendors.  It is
27 intended to be easy to port and to debug, and runs on many
28 supported architectures, including PPC, ARM, MIPS, x86, m68k, NIOS,
29 and Microblaze.
30
31 %ifarch %{arm}
32 %global use_mmc_storage 1
33 %endif
34
35 %prep
36 %setup -q
37
38 %build
39 cp %{SOURCE1001} .
40 make distclean
41 make tizen_tm1_config
42
43 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" HOSTSTRIP=/bin/true tools
44
45 %if 1%{?use_mmc_storage}
46 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" CONFIG_ENV_IS_IN_MMC=y env
47 %else
48 make %{?_smp_mflags} HOSTCC="gcc $RPM_OPT_FLAGS" env
49 %endif
50
51 export PATH="$PATH:tools"
52 make %{?_smp_mflags} EXTRAVERSION=`echo %{vcs} | sed 's/.*u-boot.*#\(.\{9\}\).*/-g\1-TIZEN.org/'`
53
54 # Sign u-boot-multi.bin - output is: u-boot-mmc.bin
55 chmod 755 tools/mkimage_signed.sh
56 mkimage_signed.sh u-boot.bin "tizen_tm1"
57
58 %install
59 rm -rf %{buildroot}
60
61 # u-boot installation
62 mkdir -p %{buildroot}/var/tmp/u-boot
63 install -d %{buildroot}/var/tmp/u-boot
64 install -m 755 u-boot.bin %{buildroot}/var/tmp/u-boot
65 install -m 755 u-boot-mmc.bin %{buildroot}/var/tmp/u-boot
66
67 %clean
68
69 %files -n u-boot-tm1
70 %manifest u-boot-tm1.manifest
71 %defattr(-,root,root,-)
72 /var/tmp/u-boot