Initial packaging for Tizen
[profile/ivi/gobject-introspection.git] / packaging / gobject-introspection.spec
1 %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4 Name:           gobject-introspection
5 Version:        1.32.1
6 Release:        1%{?dist}
7 Summary:        Introspection system for GObject-based libraries
8
9 Group:      Development/Libraries
10 License:        GPLv2+, LGPLv2+, MIT
11 URL:            http://live.gnome.org/GObjectIntrospection
12 #VCS:           git:git://git.gnome.org/gobject-introspection
13 Source0:        http://download.gnome.org/sources/gobject-introspection/1.32/%{name}-%{version}.tar.xz
14
15 Obsoletes:      gir-repository
16
17 BuildRequires:  glib2-devel
18 BuildRequires:  python-devel >= 2.5
19 BuildRequires:  gettext
20 BuildRequires:  flex
21 BuildRequires:  bison
22 BuildRequires:  libffi-devel
23 BuildRequires:  mesa-libGL-devel
24 BuildRequires:  cairo-gobject-devel
25 BuildRequires:  libxml2-devel
26 BuildRequires:  libXfixes-devel
27 BuildRequires:  libX11-devel
28 BuildRequires:  fontconfig-devel
29 BuildRequires:  libXft-devel
30 BuildRequires:  freetype-devel
31 # Bootstrap requirements
32 BuildRequires:  gnome-common
33 BuildRequires:  intltool
34 BuildRequires:  gtk-doc
35
36 %description
37 GObject Introspection can scan C header and source files in order to
38 generate introspection "typelib" files.  It also provides an API to examine
39 typelib files, useful for creating language bindings among other
40 things.
41
42 %package devel
43 Summary: Libraries and headers for gobject-introspection
44 Group: Development/Libraries
45 Requires: %name = %{version}-%{release}
46 Requires: glib2-devel
47 Requires: pkgconfig
48 # Not always, but whatever, it's a tiny dep to pull in
49 Requires: libtool
50 Obsoletes: gir-repository-devel
51
52 %description devel
53 Libraries and headers for gobject-introspection
54
55 %prep
56 %setup -q
57
58 %build
59 (if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; CONFIGFLAGS=--enable-gtk-doc; fi;
60  %configure $CONFIGFLAGS)
61 make V=1 %{?_smp_mflags}
62
63 %install
64 make install DESTDIR=$RPM_BUILD_ROOT
65
66 # Die libtool, die.
67 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
68 find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
69
70 %post -p /sbin/ldconfig
71
72 %postun -p /sbin/ldconfig
73
74 %files
75 %doc COPYING
76
77 %{_libdir}/lib*.so.*
78 %dir %{_libdir}/girepository-1.0
79 %{_libdir}/girepository-1.0/*.typelib
80
81 %files devel
82 %{_libdir}/lib*.so
83 %dir %{_libdir}/gobject-introspection
84 %{_libdir}/gobject-introspection/*
85 %{_libdir}/pkgconfig/*
86 %{_includedir}/*
87 %{_bindir}/g-ir-*
88 %{_datadir}/gir-1.0
89 %dir %{_datadir}/gobject-introspection-1.0
90 %{_datadir}/gobject-introspection-1.0/*
91 %{_datadir}/aclocal/introspection.m4
92 %{_mandir}/man1/*.gz
93 %dir %{_datadir}/gtk-doc/html/gi
94 %{_datadir}/gtk-doc/html/gi/*
95
96 %changelog
97 * Fri Apr 20 2012 Kalev Lember <kalevlember@gmail.com> - 1.32.1-1
98 - Update to 1.32.1
99
100 * Tue Mar 27 2012 Matthias Clasen <mclasen@redhat.com> 0 1.32.0-1
101 - Update to 1.32.0
102
103 * Wed Mar 21 2012 Matthias Clasen <mclasen@redhat.com> 0 1.31.22-1
104 - Update to 1.31.22
105
106 * Mon Mar  5 2012 Matthias Clasen <mclasen@redhat.com> 0 1.31.20-1
107 - Update to 1.31.20
108
109 * Thu Jan 19 2012 Matthias Clasen <mclasen@redhat.com> 0 1.31.10-1
110 - Update to 1.31.10
111
112 * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.31.6-2
113 - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
114
115 * Tue Dec 20 2011 Matthias Clasen <mclasen@redha.com> - 1.31.6-1
116 - Update to 1.31.6
117
118 * Mon Dec 05 2011 Karsten Hopp <karsten@redhat.com> 1.31.0-2
119 - add fix for PPC failure, bugzilla 749604
120
121 * Wed Nov 16 2011 Colin Walters <walters@verbum.org> - 1.31.0-2
122 - -devel package requires libtool
123   https://bugzilla.redhat.com/show_bug.cgi?id=613466
124
125 * Wed Nov  2 2011 Matthias Clasen <mclasen@redhat.com> - 1.31.0-1
126 - Update to 1.31.0
127
128 * Mon Sep 26 2011 Ray <rstrode@redhat.com> - 1.30.0-1
129 - Update to 1.30.0
130
131 * Tue Sep 20 2011 Matthias Clasen <mclasen@redhat.com> - 1.30.0-1
132 - Update to 1.30.0
133
134 * Fri Jun 17 2011 Tomas Bzatek <tbzatek@redhat.com> - 1.29.0-1
135 - Update to 1.29.0
136
137 * Thu Apr 21 2011 John (J5) Palmieri <johnp@redhat.com> - 0.10.8-1
138 - Update to 0.10.8
139
140 * Mon Apr  4 2011 Matthias Clasen <mclasen@redhat.com> - 0.10.7-1
141 - Update to 0.10.7
142
143 * Fri Mar 25 2011 Owen Taylor <otaylor@redhat.com> - 0.10.6-1
144 - New upstream release to fix missing cairo typelib
145
146 * Fri Mar 25 2011 Colin Walters <walters@verbum.org> - 0.10.5-1
147 - New upstream release, fixes cairo.gir
148   Necessary to avoid gnome-shell having a cairo-devel dependency.
149 - Also add cairo-gobject-devel dependency, since we really want
150   the cairo typelib to link to GObject, since anyone using
151   introspection has it anyways.
152
153 * Thu Mar 10 2011 Colin Walters <walters@verbum.org> - 0.10.4-1
154 - Update to 0.10.4
155
156 * Wed Feb 23 2011 Colin Walters <walters@verbum.org> - 0.10.3-1
157 - Update to 0.10.3
158
159 * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.2-2
160 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
161
162 * Mon Feb  7 2011 Colin Walters <walters@verbum.org> - 0.10.2-1
163 - Update to 0.10.2
164
165 * Wed Jan 12 2011 Colin Walters <walters@verbum.org> - 0.10.1-1
166 - Update to 0.10.1
167
168 * Mon Jan 10 2011 Owen Taylor <otaylor@redhat.com> - 0.10.0-1
169 - Update to 0.10.0
170
171 * Thu Sep 30 2010 Colin Walters <walters@verbum.org> - 0.9.10-1
172 - Update to 0.9.10
173
174 * Thu Sep 30 2010 Colin Walters <walters@verbum.org> - 0.9.9-1
175 - Update to 0.9.9
176
177 * Wed Sep 29 2010 Matthias Clasen <mclasen@redhat.com> - 0.9.8-1
178 - Update to 0.9.8
179
180 * Tue Sep 28 2010 Colin Walters <walters@verbum.org> - 0.9.7-1
181 - Update to 0.9.7
182
183 * Tue Sep 21 2010 Owen Taylor <otaylor@redhat.com> - 0.9.6-1
184 - Update to 0.9.6
185
186 * Thu Sep  2 2010 Colin Walters <walters@verbum.org> - 0.9.3-6
187 - Strip out test libraries; they're gone in upstream git, and
188   create a dependency on cairo (which requires libX11, which makes
189   server operating system builders freak out).
190
191 * Tue Aug  3 2010 Matthias Clasen <mclasen@redhat.com> - 0.9.3-1
192 - Update to 0.9.3
193
194 * Mon Jul 26 2010 David Malcolm <dmalcolm@redhat.com> - 0.9.2-5
195 - Cherrypick patch for python 2.7 compatibility (patch 1; rhbz#617782)
196
197 * Wed Jul 14 2010 Colin Walters <walters@verbum.org> - 0.9.2-4
198 - Backport patch from upstream for better errors
199
200 * Mon Jul 12 2010 Colin Walters <walters@verbum.org> - 0.9.2-1
201 - New upstream (unstable series) release; requires rebuilds
202
203 * Tue Jun 29 2010 Colin Walters <walters@verbum.org> - 0.9.0-1.4.20100629gitf0599b0a
204 - Add gtk-doc to files
205
206 * Tue Jun 29 2010 Colin Walters <walters@verbum.org>
207 - Switch to git snapshot; I forgot to enable gtk-doc in the last
208   tarball.
209
210 * Tue Jun 29 2010 Colin Walters <walters@verbum.org> - 0.9.0-1
211 - New upstream development release
212 - Update to support building git snapshot directly
213
214 * Thu Jun 24 2010 Colin Walters <walters@pocket> - 0.6.14-3
215 - rebuild to pick up new glib changes
216
217 * Thu Jun 10 2010 Colin Walters <walters@pocket> - 0.6.14-2
218 - Obsolete gir-repository{,-devel}
219
220 * Tue Jun  8 2010 Matthias Clasen <mclasen@redhat.com> - 0.6.14-1
221 - Update to 0.6.14
222
223 * Wed May 24 2010 Colin Walters <walters@verbum.org> - 0.6.12-1
224 - Update to latest upstream release 0.6.12
225
226 * Thu Mar 25 2010 Colin Walters <walters@verbum.org> - 0.6.9-3
227 - Move python library back into /usr/lib/gobject-introspection.  I put
228   it there upstream for a reason, namely that apps need to avoid
229   polluting the global Python site-packages with bits of their internals.
230   It's not a public API.
231   
232   Possibly resolves bug #569885
233
234 * Wed Mar 24 2010 Adam Miller <maxamillion@fedoraproject.org> - 0.6.9-2
235 - Added newly owned files (gobject-introspection-1.0 directory)
236
237 * Wed Mar 24 2010 Adam Miller <maxamillion@fedoraproject.org> - 0.6.9-1
238 - Update to latest upstream release 0.6.9
239
240 * Thu Mar 11 2010 Colin Walters <walters@verbum.org> - 0.6.8-0.3.20100311git2cc97351
241 - rebuilt
242
243 * Thu Mar 11 2010 Colin Walters <walters@verbum.org>
244 - New upstream snapshot
245 - rm unneeded rm
246
247 * Thu Jan 28 2010 Adam Miller <maxamillion@fedoraproject.org> - 0.6.8-0.1.20100128git
248 - Update to new git snapshot
249 - Fix Version tag to comply with correct naming use with alphatag
250
251 * Thu Jan 15 2010 Adam Miller <maxamillion@fedoraproject.org> - 0.6.7.20100115git-1
252 - Update to git snapshot for rawhide 
253
254 * Tue Dec 22 2009 Matthias Clasen <mclasen@redhat.com> - 0.6.7-1
255 - Update to 0.6.7
256
257 * Fri Sep 11 2009 Colin Walters <walters@verbum.org> - 0.6.5-1
258 - New upstream
259 - Drop libtool dep 
260
261 * Fri Aug 28 2009 Colin Walters <walters@verbum.org> - 0.6.4-2
262 - Add dep on libtool temporarily
263
264 * Mon Aug 26 2009 Colin Walters <walters@verbum.org> - 0.6.4-1
265 - New upstream 0.6.4
266 - Drop upstreamed build fix patch 
267
268 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.3-5
269 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
270
271 * Mon Jul  6 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-4
272 - Add upstream patch to fix a build crash
273
274 * Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-3
275 - Add -ggdb temporarily so it compiles on ppc64
276
277 * Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-2
278 - Add the new source file
279
280 * Thu Jul  2 2009 Peter Robinson <pbrobinson@gmail.com> - 0.6.3-1
281 - Update to 0.6.3
282
283 * Mon Jun  1 2009 Dan Williams <dcbw@redhat.com> - 0.6.2-1
284 - Update to 0.6.2
285
286 * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2
287 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
288
289 * Thu Dec 11 2008 Colin Walters <walters@verbum.org> - 0.6.1-1
290 - Update to 0.6.1
291
292 * Fri Oct 31 2008 Colin Walters <walters@verbum.org> - 0.6.0-1
293 - Create spec goo