updated spec to install with xwalk
[profile/ivi/GhostCluster.git] / packaging / GhostCluster.spec
1 Name:       GhostCluster
2 Summary:    Automotive Meter Cluster Application
3 Version:    0.2013.10.16
4 Release:    1
5 Group:      Applications/System
6 License:    Apache 2.0
7 URL:        http://www.tizen.org
8 Source0:    %{name}-%{version}.tar.gz
9 BuildRequires: zip
10 Requires: crosswalk
11 Requires: tizen-platform-config
12
13 %description
14 Example guage cluster for tizen ivi
15
16 %prep
17 %setup -q -n %{name}-%{version}
18
19 %build
20 make widget
21
22 %install
23 rm -rf %{buildroot}
24
25 %make_install
26
27 %post 
28 source %_sysconfdir/tizen-platform.conf
29 export DBUS_SESSION_BUS_ADDRESS="unix:path=/run/user/5000/dbus/user_bus_socket"
30
31 su app -c "xwalkctl -i /opt/usr/apps/.preinstallWidgets/GhostCluster.wgt"
32
33 %postun
34
35 su app -c "xwalkctl -u $(su %{MODELLO_INSTALL_USER} -c "xwalkctl" | grep GhostCluster | cut -c 1-32)
36
37 %files
38 %defattr(-,root,root,-)
39 #%manifest gc.manifest
40 /opt/usr/apps/.preinstallWidgets/GhostCluster.wgt