746f4a945cbe39e5543a084a18b6a8638fe534fa
[platform/upstream/nettle.git] / packaging / nettle.spec
1 Name:           nettle
2 Version:        3.2
3 Release:        0
4 Summary:        Cryptographic Library
5 License:        LGPL-2.1+ and GPL-2.0+
6 Group:          Security/Crypto Libraries
7 Source0:        https://ftp.gnu.org/gnu/nettle/nettle-%{version}.tar.gz
8 Source1:        baselibs.conf
9 Source1001:     nettle.manifest
10 BuildRequires:  gmp-devel
11 BuildRequires:  pkgconfig
12
13 %description
14 Nettle is a cryptographic library that is designed to fit easily in more or
15 less any context: In crypto toolkits for object-oriented languages (C++,
16 Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space.
17
18 %package -n libhogweed
19
20 Summary:        Cryptographic Library for Public Key Algorithms
21 License:        LGPL-2.1+
22 Group:          Security/Crypto Libraries
23
24 %description -n libhogweed
25 Nettle is a cryptographic library that is designed to fit easily in more or
26 less any context: In crypto toolkits for object-oriented languages (C++,
27 Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space.
28
29 The libhogweed library contains public key algorithms to use with libnettle.
30
31 %package -n libnettle-devel
32 Summary:        Cryptographic Library
33 License:        LGPL-2.1+
34 Group:          Development/Libraries
35 Requires:       glibc-devel
36 Requires:       gmp-devel
37 Requires:       libhogweed = %{version}
38 Requires:       libnettle = %{version}
39
40 %description -n libnettle-devel
41 Nettle is a cryptographic library that is designed to fit easily in more or
42 less any context: In crypto toolkits for object-oriented languages (C++,
43 Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space.
44
45 %package -n libnettle
46
47 Summary:        Cryptographic Tools
48 License:        LGPL-2.1+ and GPL-2.0+
49 Group:          Security/Crypto Libraries
50
51 %description -n libnettle
52 Nettle is a cryptographic library that is designed to fit easily in more or
53 less any context: In crypto toolkits for object-oriented languages (C++,
54 Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space.
55
56 This package contains a few command-line tools to perform cryptographic
57 operations using the nettle library.
58
59 %prep
60 %setup -q
61 cp %{SOURCE1001} .
62
63 %build
64 #configure --disable-static
65 %configure --enable-shared
66
67 make %{?_smp_mflags}
68
69 %check
70 make check
71
72 %install
73 %make_install
74
75 %post   -n libnettle -p /sbin/ldconfig
76
77 %postun -n libnettle -p /sbin/ldconfig
78
79 %post   -n libhogweed -p /sbin/ldconfig
80
81 %postun -n libhogweed -p /sbin/ldconfig
82
83
84 %files -n libnettle
85 %manifest %{name}.manifest
86 %defattr(-,root,root)
87 %license COPYING*
88 %{_libdir}/libnettle.so.*
89
90 %files -n libhogweed
91 %manifest %{name}.manifest
92 %defattr(-,root,root)
93 %{_libdir}/libhogweed.so.*
94
95 %files -n libnettle-devel
96 %manifest %{name}.manifest
97 %defattr(-,root,root)
98 %{_includedir}/nettle
99 %{_libdir}/libnettle.so
100 %{_libdir}/libhogweed.so
101 %{_libdir}/pkgconfig/hogweed.pc
102 %{_libdir}/pkgconfig/nettle.pc
103
104 %files -n nettle
105 %manifest %{name}.manifest
106 %defattr(-,root,root)
107 %{_bindir}/nettle-lfib-stream
108 %{_bindir}/pkcs1-conv
109 %{_bindir}/sexp-conv
110 %{_bindir}/nettle-hash
111 %{_bindir}/nettle-pbkdf2
112 %changelog