1fc62b4d1db03d4c7e4ce3c902938f2f2a74a295
[platform/upstream/mtools.git] / mtools.spec
1 %define _binary_payload w9.gzdio
2 Name:           mtools
3 Summary:        mtools, read/write/list/format DOS disks under Unix
4 Version:        4.0.18
5 Release:        1
6 License:        GPLv3+
7 Group:          Utilities/System
8 URL:            http://www.gnu.org/software/mtools/
9 Source:         ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.gz
10 Buildroot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
11
12
13 %description
14 Mtools is a collection of utilities to access MS-DOS disks from GNU
15 and Unix without mounting them. It supports long file names, OS/2 Xdf
16 disks, ZIP/JAZ disks and 2m disks (store up to 1992k on a high density
17 3 1/2 disk).
18
19
20 %prep
21 %setup -q
22
23 ./configure \
24     --prefix=%{buildroot}%{_prefix} \
25     --sysconfdir=/etc \
26     --infodir=%{buildroot}%{_infodir} \
27     --mandir=%{buildroot}%{_mandir} \
28     --enable-floppyd \
29
30 %build
31 make
32
33 %clean
34 echo rm -rf $RPM_BUILD_ROOT
35 [ X%{buildroot} != X ] && [ X%{buildroot} != X/ ] && rm -fr %{buildroot}
36
37 %install
38 make install
39 make install-info
40 strip %{buildroot}%{_bindir}/mtools %{buildroot}%{_bindir}/mkmanifest %{buildroot}%{_bindir}/floppyd
41 rm %{buildroot}%{_infodir}/dir
42
43 %files
44 %defattr(-,root,root)
45 %{_infodir}/mtools.info*
46 %{_mandir}/man1/floppyd.1*
47 %{_mandir}/man1/floppyd_installtest.1.gz
48 %{_mandir}/man1/mattrib.1*
49 %{_mandir}/man1/mbadblocks.1*
50 %{_mandir}/man1/mcat.1*
51 %{_mandir}/man1/mcd.1*
52 %{_mandir}/man1/mclasserase.1*
53 %{_mandir}/man1/mcopy.1*
54 %{_mandir}/man1/mdel.1*
55 %{_mandir}/man1/mdeltree.1*
56 %{_mandir}/man1/mdir.1*
57 %{_mandir}/man1/mdu.1*
58 %{_mandir}/man1/mformat.1*
59 %{_mandir}/man1/minfo.1*
60 %{_mandir}/man1/mkmanifest.1*
61 %{_mandir}/man1/mlabel.1*
62 %{_mandir}/man1/mmd.1*
63 %{_mandir}/man1/mmount.1*
64 %{_mandir}/man1/mmove.1*
65 %{_mandir}/man1/mpartition.1*
66 %{_mandir}/man1/mrd.1*
67 %{_mandir}/man1/mren.1*
68 %{_mandir}/man1/mshortname.1*
69 %{_mandir}/man1/mshowfat.1*
70 %{_mandir}/man1/mtools.1*
71 %{_mandir}/man5/mtools.5*
72 %{_mandir}/man1/mtoolstest.1*
73 %{_mandir}/man1/mtype.1*
74 %{_mandir}/man1/mzip.1*
75 %{_bindir}/amuFormat.sh
76 %{_bindir}/mattrib
77 %{_bindir}/mbadblocks
78 %{_bindir}/mcat
79 %{_bindir}/mcd
80 %{_bindir}/mclasserase
81 %{_bindir}/mcopy
82 %{_bindir}/mdel
83 %{_bindir}/mdeltree
84 %{_bindir}/mdir
85 %{_bindir}/mdu
86 %{_bindir}/mformat
87 %{_bindir}/minfo
88 %{_bindir}/mkmanifest
89 %{_bindir}/mlabel
90 %{_bindir}/mmd
91 %{_bindir}/mmount
92 %{_bindir}/mmove
93 %{_bindir}/mpartition
94 %{_bindir}/mrd
95 %{_bindir}/mren
96 %{_bindir}/mshortname
97 %{_bindir}/mshowfat
98 %{_bindir}/mtools
99 %{_bindir}/mtoolstest
100 %{_bindir}/mtype
101 %{_bindir}/mzip
102 %{_bindir}/floppyd
103 %{_bindir}/floppyd_installtest
104 %{_bindir}/mcheck
105 %{_bindir}/mcomp
106 %{_bindir}/mxtar
107 %{_bindir}/tgz
108 %{_bindir}/uz
109 %{_bindir}/lz
110 %doc NEWS
111
112 %pre
113 groupadd floppy 2>/dev/null || echo -n ""
114
115 %post
116 if [ -f %{_bindir}/install-info ] ; then
117         if [ -f %{_infodir}/dir ] ; then
118                 %{_bindir}/install-info %{_infodir}/mtools.info %{_infodir}/dir
119         fi
120         if [ -f %{_infodir}/dir.info ] ; then
121                 %{_bindir}/install-info %{_infodir}/mtools.info %{_infodir}/dir.info
122         fi
123 fi
124
125
126 %preun
127 install-info --delete %{_infodir}/mtools.info %{_infodir}/dir.info
128 if [ -f %{_bindir}/install-info ] ; then
129         if [ -f %{_infodir}/dir ] ; then
130                 %{_bindir}/install-info --delete %{_infodir}/mtools.info %{_infodir}/dir
131         fi
132         if [ -f %{_infodir}/dir.info ] ; then
133                 %{_bindir}/install-info --delete %{_infodir}/mtools.info %{_infodir}/dir.info
134         fi
135 fi
136
137 %changelog
138 * Wed Jan 09 2013 Alain Knaff <alain@knaff.lu>
139 - Fix for names of iconv encodings on AIX
140 - Fix mt_size_t on NetBSD
141 - Fixed compilation on Mingw
142 - Fixed doc (especially mformat)
143 - Fix mformating of FAT12 filesystems with huge cluster sizes
144 - Minfo prints image file name in mformat command line if an image
145 - file name was given
146 - Always generate gzip-compressed RPMs, in order to remain
147 - compatible with older distributions
148 - Fixed buffer overflow with drive letter in mclasserase
149 * Wed Jun 29 2011 Alain Knaff <alain@knaff.lu>
150 - mbadblocks now takes a list of bad blocks (either as sectors
151   or as clusters)
152 - mbadblocks now is able to do write scanning for bad blocks
153 - mshowfat can show cluster of specific offset
154 - Enable mtools to deal with very small sector sizes...
155 - Fixed encoding of all-lowercase names (no need to mangle
156   these)
157 - Consider every directory entry after an ENDMARK (0x00) to be deleted
158 - After writing a new entry at end of a directory, be sure to also add
159   an ENDMARK (0x00)
160 - Deal with possibility of a NULL pointer being returned by
161   localtime during timestamp conversion
162 * Sat Apr 16 2011 Alain Knaff <alain@knaff.lu>
163 - configure.in fixes
164 - fixed formatting of fat_size_calculation.tex document
165 - compatibility with current autoconfig versions
166 - Make it clear that label is limited to 11 characters
167 - Fixed typo in initialization of FAT32 info sector
168 * Sun Oct 17 2010 Alain Knaff <alain@knaff.lu>
169 - Added missing -i option to mshortname
170 * Sun Oct 17 2010 Alain Knaff <alain@knaff.lu>
171 - Released v4_0_14:
172 - New mshortname command
173 - Fix floppyd for disks bigger than 2 Gig
174 - Remove obsolete -z flag
175 - Remove now unsupported AC_USE_SYSTEM_EXTENSIONS
176 - Fixed output formatting of mdir if MTOOLS_DOTTED_DIR is set
177 - Mformat now correctly writes backup boot sector
178 - Fixed signedness of serial number in mlabel
179 - Fixed buffer size problem in mlabel
180 - Make mlabel write backup boot sector if FAT32
181 - Catch situation where both clear and new label are given to mlabel
182 - Quote filename parameters to scripts
183 - Mformat: Close file descriptor for boot sector
184 - Added lzip support to scripts/uz
185 - Added Tot_sectors option to mformat
186 - Fixed hidden sector handling in mformat
187 - Minfo generates mformat command lines containing new -T option
188 - Mlabel prints error if label too long
189 * Sun Feb 28 2010 Alain Knaff <alain@knaff.lu>
190 - Merged Debian patches
191 * Tue Nov 03 2009 Alain Knaff <alain@knaff.lu>
192 - Mingw compatibility fixes