add packaging
[platform/upstream/mpc.git] / packaging / mpc.spec
1 #
2 # spec file for package mpc
3 #
4 # Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
5 #
6 # All modifications and additions to the file contributed by third parties
7 # remain the property of their copyright owners, unless otherwise agreed
8 # upon. The license for this file, and modifications and additions to the
9 # file, is the same license as for the pristine package itself (unless the
10 # license for the pristine package is not an Open Source License, in which
11 # case the license is the MIT License). An "Open Source License" is a
12 # license that conforms to the Open Source Definition (Version 1.9)
13 # published by the Open Source Initiative.
14
15 # Please submit bugfixes or comments via http://bugs.opensuse.org/
16 #
17
18
19 Name:           mpc
20 Version:        1.0
21 Release:        0
22 License:        LGPL-3.0+
23 Summary:        MPC multiple-precision complex shared library
24 Url:            http://www.multiprecision.org/mpc/
25 Group:          Development/Libraries/C and C++
26 Source:         mpc-%{version}.tar.bz2
27 Source2:        baselibs.conf
28 BuildRequires:  gmp-devel
29 BuildRequires:  mpfr-devel
30 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
31
32 %description
33 MPC is a C library for the arithmetic of complex numbers with
34 arbitrarily high precision and correct rounding of the result. It is
35 built upon and follows the same principles as MPFR.
36
37 %package -n libmpc
38 Summary:        MPC multiple-precision complex shared library
39 Group:          Development/Libraries/C and C++
40
41 %description -n libmpc
42 MPC is a C library for the arithmetic of complex numbers with
43 arbitrarily high precision and correct rounding of the result. It is
44 built upon and follows the same principles as MPFR.
45
46 %package devel
47 Summary:        MPC multiple-precision complex library development files
48 Group:          Development/Libraries/C and C++
49 Requires:       libmpc = %{version}
50 Requires:       mpfr-devel
51
52 %description devel
53 MPC multiple-precision complex library development files.
54
55 %prep
56 %setup -q
57
58 %build
59 %configure
60 make %{?_smp_mflags}
61
62 %check
63 make check %{?_smp_mflags}
64
65 %install
66 %make_install
67 rm %{buildroot}%{_libdir}/libmpc.la
68
69 %post -n libmpc -p /sbin/ldconfig
70
71
72 %postun -n libmpc -p /sbin/ldconfig
73
74
75 %files -n libmpc
76 %defattr(-,root,root)
77 %{_libdir}/libmpc.so.3*
78
79 %files devel
80 %defattr(-,root,root)
81 %doc AUTHORS NEWS COPYING.LESSER
82 %doc %{_infodir}/mpc.info.gz
83 %{_libdir}/libmpc.a
84 %{_libdir}/libmpc.so
85 /usr/include/mpc.h
86
87 %changelog