resetting manifest requested domain to floor
[platform/upstream/monotype-fonts.git] / packaging / monotype-fonts.spec
1 %define _fontsdir               %{_datadir}/fonts
2 %define _ttffontsdir            %{_fontsdir}/truetype
3 %define _miscfontsdir           %{_fontsdir}/misc
4 %define _fontsconfdir           %{_sysconfdir}/fonts
5 %define _fontsconfddir          %{_fontsconfdir}/conf.d
6 %define _fontsconfavaildir      %{_datadir}/%{name}/conf.avail
7
8 Name:           monotype-fonts
9 Version:        0.0.1
10 Release:        0
11 License:        Intel Proprietary
12 Summary:        Fonts package that provides the Clear Sans font
13 Url:            http://www.intel.com/
14 Group:          System/Fonts
15 Source:         %{name}-%{version}.tar.xz
16 Source1001:     monotype-fonts.manifest
17 BuildArch:      noarch
18 Requires(post): %{_bindir}/fc-cache
19
20 %description
21 Fonts package that provides the Clear Sans font
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28
29 %install
30 mkdir -p %{buildroot}%{_ttffontsdir}
31 install -m 0644 ttf/*.ttf %{buildroot}%{_ttffontsdir}/
32
33 %post
34 if [ -x %{_bindir}/fc-cache ]; then
35     %{_bindir}/fc-cache %{_ttffontsdir} || :
36 fi
37
38 %postun
39 if [ -x %{_bindir}/fc-cache ]; then
40     %{_bindir}/fc-cache %{_ttffontsdir} || :
41 fi
42
43 %files
44 %manifest %{name}.manifest
45 %license COPYING
46 %{_ttffontsdir}/*.ttf