Bump to 4.4
[platform/upstream/make.git] / packaging / make.spec
1 %define __spec_check_pre exit 0
2
3 Name:           make
4 Url:            http://www.gnu.org/software/make/make.html
5 Provides:       gmake
6 Version:        4.4
7 Release:        0
8 Summary:        GNU make
9 License:        GPL-3.0+
10 Group:          Platform Development/Build
11 Source:         make-%{version}.tar.bz2
12 Source1001:     make.manifest
13 BuildRequires:  makeinfo
14
15 %description
16 The GNU make command with extensive documentation.
17
18 %prep
19 %setup -q
20 cp %{SOURCE1001} .
21
22 %build
23 export AUTOPOINT=true %{?asan:LIBS+=" -ldl "}
24 export CFLAGS+=" -fPIC "
25 export CXXFLAGS+=" -fPIC "
26 export LDFLAGS+=" -pie "
27 %reconfigure --disable-nls
28 %__make %{?_smp_mflags}
29
30 %check
31 %__make check
32
33 %install
34 %make_install
35 ln -sf make %{buildroot}%{_bindir}/gmake
36
37 %files
38 %manifest %{name}.manifest
39 %defattr(-,root,root)
40 %license COPYING
41 %{_bindir}/make
42 %{_bindir}/gmake
43 %{_includedir}/gnumake.h
44 %doc %{_infodir}/make.info-*.gz
45 %doc %{_infodir}/make.info.gz
46 %doc %{_mandir}/man1/make.1.gz
47
48 %post
49 %install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
50
51 %postun
52 %install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz