packaging: Initial packaging
[platform/upstream/make.git] / packaging / make.spec
1 #
2 # Do NOT Edit the Auto-generated Part!
3 # Generated by: spectacle version 0.22
4 #
5 # >> macros
6 # << macros
7
8 Name:           make
9 Version:        3.81
10 Release:        1
11 License:        GPL-2.0+
12 Summary:        A GNU tool which simplifies the build process for users
13 Url:            http://www.gnu.org/software/make/
14 Group:          Development/Tools
15 Source0:        ftp://ftp.gnu.org/gnu/make/make-%{version}.tar.bz2
16 Source100:      make.yaml
17 Patch0:         make-3.79.1-noclock_gettime.patch
18 Patch1:         make-3.80-j8k.patch
19 Patch2:         make-3.80-getcwd.patch
20 Patch3:         make-3.81-err-reporting.patch
21 Patch4:         make-3.81-memory.patch
22 Patch5:         make-3.81-rlimit.patch
23 Patch6:         make-3.81-newlines.patch
24 Patch7:         make-3.81-jobserver.patch
25
26 %description
27 A GNU tool for controlling the generation of executables and other
28 non-source files of a program from the program's source files. Make
29 allows users to build and install packages without any significant
30 knowledge about the details of the build process. The details about
31 how the program should be built are provided for make in the program's
32 makefile.
33
34 %prep
35 %setup -q
36
37 # make-3.79.1-noclock_gettime.patch
38 %patch0 -p1
39 # make-3.80-j8k.patch
40 %patch1 -p1
41 # make-3.80-getcwd.patch
42 %patch2 -p1
43 # make-3.81-err-reporting.patch
44 %patch3 -p1
45 # make-3.81-memory.patch
46 %patch4 -p1
47 # make-3.81-rlimit.patch
48 %patch5 -p1
49 # make-3.81-newlines.patch
50 %patch6 -p1
51 # make-3.81-jobserver.patch
52 %patch7 -p1
53 # >> setup
54 # << setup
55
56 %build
57 # >> build pre
58 # << build pre
59
60 %configure --disable-static \
61     --disable-nls
62
63 make %{?_smp_mflags}
64
65 # >> build post
66 # << build post
67 %install
68 # >> install pre
69 # << install pre
70 %make_install
71
72 # >> install post
73 ln -sf make %{buildroot}%{_bindir}/gmake
74 ln -sf make.1 %{buildroot}%{_mandir}/man1/gmake.1
75 rm -rf %{buildroot}%{_infodir}
76 # << install post
77
78
79
80
81
82
83 %files
84 %defattr(-,root,root,-)
85 # >> files
86 %doc NEWS README COPYING AUTHORS
87 %{_bindir}/*
88 %doc %{_mandir}/man*/*
89 # << files
90
91