packaging: Bump to version 4.0
[platform/upstream/make.git] / packaging / make.spec
1 Name:           make
2 Url:            http://www.gnu.org/software/make/make.html
3 Provides:       gmake
4 Version:        4.0
5 Release:        0
6 Summary:        GNU make
7 License:        GPL-2.0+
8 Group:          Platform Development/Build
9 Source:         make-%{version}.tar.bz2
10 Source1001:     make.manifest
11 BuildRequires:  makeinfo
12
13 %description
14 The GNU make command with extensive documentation.
15
16 %prep
17 %setup -q
18 cp %{SOURCE1001} .
19
20 %build
21 export AUTOPOINT=true
22 %reconfigure --disable-nls
23 %__make %{?_smp_mflags}
24
25 %check
26 %__make check
27
28 %install
29 %make_install
30 ln -sf make %{buildroot}%{_bindir}/gmake
31
32 %files 
33 %manifest %{name}.manifest
34 %defattr(-,root,root)
35 %license COPYING
36 %{_bindir}/make
37 %{_bindir}/gmake
38 %{_includedir}/gnumake.h
39 %doc %{_infodir}/make.info-*.gz
40 %doc %{_infodir}/make.info.gz
41 %doc %{_mandir}/man1/make.1.gz
42
43 %post
44 %install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
45
46 %postun
47 %install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz