Change make license
[platform/upstream/make.git] / packaging / make.spec
1 %define __spec_check_pre exit 0
2
3 Name:           make
4 Url:            http://www.gnu.org/software/make/make.html
5 Provides:       gmake
6 Version:        4.3
7 Release:        0
8 Summary:        GNU make
9 License:        GPL-3.0+
10 Group:          Platform Development/Build
11 Source:         make-%{version}.tar.bz2
12 Source1001:     make.manifest
13 BuildRequires:  makeinfo
14
15 %description
16 The GNU make command with extensive documentation.
17
18 %prep
19 %setup -q
20 cp %{SOURCE1001} .
21
22 %build
23 export AUTOPOINT=true %{?asan:LIBS+=" -ldl "}
24 %reconfigure --disable-nls
25 %__make %{?_smp_mflags}
26
27 %check
28 %__make check
29
30 %install
31 %make_install
32 ln -sf make %{buildroot}%{_bindir}/gmake
33
34 %files
35 %manifest %{name}.manifest
36 %defattr(-,root,root)
37 %license COPYING
38 %{_bindir}/make
39 %{_bindir}/gmake
40 %{_includedir}/gnumake.h
41 %doc %{_infodir}/make.info-*.gz
42 %doc %{_infodir}/make.info.gz
43 %doc %{_mandir}/man1/make.1.gz
44
45 %post
46 %install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz
47
48 %postun
49 %install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info.gz