Fix build with gcc-6
[platform/upstream/lzop.git] / packaging / lzop.spec
1 Name:           lzop
2 Version:        1.03
3 Release:        1
4 License:        GPLv2+
5 Summary:        lzop
6 URL:            http://www.lzop.org
7 Group:          Applications/Text
8 Source:         %{name}-%{version}.tar.gz
9 Source1001: lzop.manifest 
10 BuildRequires:  lzo
11 BuildRequires:  lzo-devel
12
13
14 %description
15 lzop is a file compressor which is very similar to gzip. lzop uses
16 the LZO data compression library for compression services, and its
17 main advantages over gzip are much higher compression and
18 decompression speed (at the cost of some compression ratio).
19
20 lzop is copyrighted OpenSource software distributed under the terms
21 of the GNU General Public License (GPL).
22
23 %prep
24 %setup -q
25
26 %build
27 cp %{SOURCE1001} .
28 %configure --disable-nls
29 make PR_PROGRAM=%{_bindir}/pr
30
31 %install
32 %make_install
33
34 %clean
35 rm -rf %{buildroot}
36
37 %docs_package 
38
39 %files 
40 %manifest %{name}.manifest
41 %defattr(-,root,root,-)
42 %doc NEWS README COPYING
43 %{_bindir}/*
44 %{_mandir}/*/*