Adapt ASLR to ltrace
[platform/upstream/ltrace.git] / packaging / ltrace.spec
1 Name:           ltrace
2 Version:        0.7.91
3 Release:        0
4 BuildRequires:  binutils-devel
5 BuildRequires:  gcc-c++
6 BuildRequires:  libelf-devel
7 Url:            http://ltrace.org/
8 Summary:        Trace the Library and System Calls a Program Makes
9 License:        GPL-2.0+
10 Group:          Development/Tools
11 Source:         ltrace-%{version}.tar.bz2
12 Source2:        baselibs.conf
13 Source1001:     ltrace.manifest
14
15 %description
16 Ltrace is a program that runs the specified command until it exits. It
17 intercepts and records the dynamic library calls that are called by the
18 executed process and the signals that are received by that process. It
19 can also intercept and print the system calls executed by the program.
20
21 The program to trace need not be recompiled for this, so you can use
22 ltrace on binaries for which you do not have access to the source.
23
24 This is still a work in progress, so, for example, the tracking to
25 child processes may fail or some things may not work as expected.
26
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 export CFLAGS="%{optflags} -Wall -Wno-unused-local-typedefs"
34 ./autogen.sh
35 %configure --build=%{_target_cpu}-tizen-linux
36 make
37
38 %install
39 %make_install
40 rm -rf %{buildroot}/usr/share/doc/ltrace
41
42 %files
43 %manifest %{name}.manifest
44 %defattr(-,root,root)
45 %license COPYING
46 %{_bindir}/ltrace
47 %{_mandir}/man?/ltrace.?.gz
48 %{_mandir}/man?/ltrace.conf.?.gz
49 %config /usr/share/ltrace/syscalls.conf
50 %config /usr/share/ltrace/libc.so.conf
51 %config /usr/share/ltrace/libm.so.conf
52 %config /usr/share/ltrace/libacl.so.conf
53
54 %changelog