Update .changes
[platform/upstream/lightmediascanner.git] / packaging / lightmediascanner.spec
1 Name:       lightmediascanner
2 Summary:    Light media scanner is a media indexer for embedded devices
3 Version:    0.4.5
4 Release:    2
5 Group:      Multimedia/Libraries
6 License:    LGPL-2.1
7 Source:     %{name}-%{version}.tar.gz
8 Url:        http://lms.garage.maemo.org/
9 BuildRequires: sqlite-devel
10 BuildRequires: gettext-tools
11 BuildRequires: pkgconfig(flac)
12 BuildRequires: pkgconfig(vorbis)
13
14 %define testbindir %{_builddir}/%{name}-%{version}
15
16 %description
17 Description: %{summary}
18
19 %package devel
20 Summary: LMS headers, static libraries, and documentation
21 Requires: %{name} = %{version}
22
23 %description devel
24 Headers, static libraries, and documentation for LMS
25
26 %package test
27 Summary: LMS test programs
28 Requires: %{name} = %{version}
29
30 %description test
31 LMS test programs
32
33 %prep
34 %setup -q -n %{name}-%{version}
35
36 %build
37
38 %autogen
39
40 make %{?jobs:-j%jobs}
41
42 %install
43 rm -rf %{buildroot}
44 %make_install
45
46 # Temporarily install test binaries
47 mkdir -p %{buildroot}/%{_bindir}
48 libtool --mode=install install -m 0755 %{testbindir}/src/bin/test %{buildroot}/%{_bindir}/lms-test
49 libtool --mode=install install -m 0755 %{testbindir}/src/bin/list-parsers %{buildroot}/%{_bindir}/lms-list-parsers
50
51 %post
52 /sbin/ldconfig
53
54 %postun
55 /sbin/ldconfig
56
57 %files
58 %defattr(-, root, root)
59 %doc AUTHORS README
60 %license COPYING
61 %{_libdir}/*.so.*
62 %{_libdir}/lightmediascanner/plugins/*
63
64 %files devel
65 %defattr(-, root, root)
66 %{_includedir}/*
67 %{_libdir}/*.so
68 %{_libdir}/pkgconfig/*
69
70 %files test
71 %defattr(-, root, root)
72 %{_bindir}/*