Fixed package groups
[platform/upstream/libxml2.git] / packaging / libxml2.spec
1 Name:           libxml2
2 Version:        2.8.0
3 Release:        0
4 Summary:        A Library to Manipulate XML Files
5 License:        MIT
6 Group:          System/Libraries
7 Url:            http://xmlsoft.org
8 # Source ftp://xmlsoft.org/libxml2/libxml2-git-snapshot.tar.gz changes every day
9 Source:         ftp://xmlsoft.org/libxml2/%{name}-%{version}.tar.gz
10 Source2:        baselibs.conf
11 BuildRequires:  pkg-config
12 BuildRequires:  readline-devel
13 BuildRequires:  xz-devel
14 BuildRequires:  zlib-devel
15
16 %description
17 The XML C library was initially developed for the GNOME project. It is
18 now used by many programs to load and save extensible data structures
19 or manipulate any kind of XML files.
20
21 This library implements a number of existing standards related to
22 markup languages, including the XML standard, name spaces in XML, XML
23 Base, RFC 2396, XPath, XPointer, HTML4, XInclude, SGML catalogs, and
24 XML catalogs. In most cases, libxml tries to implement the
25 specification in a rather strict way. To some extent, it provides
26 support for the following specifications, but does not claim to
27 implement them: DOM, FTP client, HTTP client, and SAX.
28
29 The library also supports RelaxNG. Support for W3C XML Schemas is in
30 progress.
31
32
33 %package tools
34 Summary:        Tools using libxml
35 Group:          System/Libraries
36
37 %description tools
38 This package contains xmllint, a very useful tool proving libxml's power.
39
40 %package devel
41 Summary:        Include Files and Libraries mandatory for Development
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}
44 Requires:       %{name}-tools = %{version}
45 Requires:       glibc-devel
46 Requires:       readline-devel
47 Requires:       xz-devel
48 Requires:       zlib-devel
49
50 %description devel
51 This package contains all necessary include files and libraries needed
52 to develop applications that require these.
53
54 %prep
55 %setup -q
56
57 %build
58 %configure --disable-static \
59     --docdir=%_docdir/%name \
60     --with-html-dir=%_docdir/%name/html \
61     --with-fexceptions \
62     --with-history \
63     --without-python \
64     --enable-ipv6 \
65     --with-sax1 \
66     --with-regexps \
67     --with-threads \
68     --with-reader \
69     --with-http
70
71 make %{?_smp_mflags} BASE_DIR="%_docdir" DOC_MODULE="%name"
72
73 %check
74 # qemu-arm can't keep up atm, disabling check for arm
75 %ifnarch %arm
76 make check
77 %endif
78
79 %install
80 make install DESTDIR="%buildroot" BASE_DIR="%_docdir" DOC_MODULE="%name"
81 ln -s libxml2/libxml %{buildroot}%{_includedir}/libxml
82
83 %remove_docs
84
85 %post -p /sbin/ldconfig
86
87 %postun -p /sbin/ldconfig
88
89 %files 
90 %defattr(-, root, root)
91 %license COPYING*
92 %{_libdir}/lib*.so.*
93
94 %files tools
95 %defattr(-, root, root)
96 %{_bindir}/xmllint
97 %{_bindir}/xmlcatalog
98
99 %files devel
100 %defattr(-, root, root)
101 %{_bindir}/xml2-config
102 %dir %{_datadir}/aclocal
103 %{_datadir}/aclocal/libxml.m4
104 %{_includedir}/libxml
105 %{_includedir}/libxml2
106 %{_libdir}/lib*.so
107 # libxml2.la is needed for the python-libxml2 build. Deleting it breaks build of python-libxml2.
108 %{_libdir}/libxml2.la
109 %{_libdir}/*.sh
110 %{_libdir}/pkgconfig/*.pc
111
112 %changelog