packaging: add disable-docs option
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
1 Name:           libxkbcommon
2 Version:        0.7.2
3 Release:        0
4 License:        MIT
5 Summary:        Wayland libxkbcommon library
6 Url:            http://wayland.freedesktop.org/
7 Group:          Development/Libraries
8
9 Source:         %{name}-%{version}.tar.xz
10 #X-Vcs-Url:     https://github.com/xkbcommon/libxkbcommon.git
11 Source1001:     libxkbcommon.manifest
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  libtool >= 2
17 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
18 BuildRequires:  python
19 BuildRequires:  xkb-tizen-data
20 BuildRequires:  gawk
21
22 %global TZ_SYS_RO_SHARE  %{?TZ_SYS_RO_SHARE:%TZ_SYS_RO_SHARE}%{!?TZ_SYS_RO_SHARE:/usr/share}
23
24 %description
25 Keyboard handling library using XKB data.
26
27 %package devel
28 Summary:        Development files for the Wayland libxkbcommon library
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Keyboard handling library using XKB data.
34
35 This package contains the development headers for the library found
36 in %{name}.
37
38 %prep
39 %setup -q
40 cp %{SOURCE1001} .
41
42 # Generate tizen keymap header
43 export TZ_SYS_RO_SHARE="%{TZ_SYS_RO_SHARE}"
44 chmod a+x ./make_tizen_keymap.sh
45 ./make_tizen_keymap.sh
46 chmod a+x ./gen_tables.sh
47 ./gen_tables.sh
48
49 %build
50 chmod a+x ./autogen.sh
51 %autogen --disable-static --disable-x11 --disable-docs
52 %__make %{?_smp_mflags} V=1;
53
54 %install
55 %make_install
56
57 %post  -p /sbin/ldconfig
58
59 %postun  -p /sbin/ldconfig
60
61 %files
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %license COPYING
65 %{_libdir}/libxkbcommon.so.0*
66
67 %files devel
68 %manifest %{name}.manifest
69 %defattr(-,root,root)
70 %{_includedir}/xkbcommon
71 %{_libdir}/libxkbcommon.so
72 %{_libdir}/pkgconfig/xkbcommon.pc
73