Modify a dependancy for install a keymap file e-tizen-data to xkb-data
[platform/upstream/libxkbcommon.git] / packaging / libxkbcommon.spec
1 Name:           libxkbcommon
2 Version:        0.4.3
3 Release:        0
4 License:        MIT
5 Summary:        Wayland libxkbcommon library
6 Url:            http://wayland.freedesktop.org/
7 Group:          Development/Libraries
8
9 Source:         %{name}-%{version}.tar.xz
10 #X-Vcs-Url:     https://github.com/xkbcommon/libxkbcommon.git
11 Source1001:     libxkbcommon.manifest
12 BuildRequires:  autoconf >= 2.60
13 BuildRequires:  automake
14 BuildRequires:  bison
15 BuildRequires:  flex
16 BuildRequires:  libtool >= 2
17 BuildRequires:  pkgconfig(xorg-macros) >= 1.8
18 %if "%{?profile}" == "common"
19 %else
20 BuildRequires:  python
21 BuildRequires:  xkb-data
22 %endif
23
24 %description
25 Keyboard handling library using XKB data.
26
27 %package devel
28 Summary:        Development files for the Wayland libxkbcommon library
29 Group:          Development/Libraries
30 Requires:       %{name} = %{version}-%{release}
31
32 %description devel
33 Keyboard handling library using XKB data.
34
35 This package contains the development headers for the library found
36 in %{name}.
37
38 %prep
39 %setup -qn %{name}
40 cp %{SOURCE1001} .
41
42 # Generate tizen keymap header except common profile
43 %if "%{?profile}" == "common"
44 %else
45 export TIZEN_PROFILE="%{?profile}"
46 chmod a+x ./make_tizen_keymap.sh
47 ./make_tizen_keymap.sh
48 chmod a+x ./gen_tables.sh
49 ./gen_tables.sh
50 %endif
51
52 %build
53 %autogen --disable-static --disable-x11 --with-tizen-profile="%{?profile}"
54 %__make %{?_smp_mflags} V=1;
55
56 %install
57 %make_install
58
59 %post  -p /sbin/ldconfig
60
61 %postun  -p /sbin/ldconfig
62
63 %files
64 %manifest %{name}.manifest
65 %defattr(-,root,root)
66 %license COPYING
67 %{_libdir}/libxkbcommon.so.0*
68
69 %files devel
70 %manifest %{name}.manifest
71 %defattr(-,root,root)
72 %{_includedir}/xkbcommon
73 %{_libdir}/libxkbcommon.so
74 %{_libdir}/pkgconfig/xkbcommon.pc
75