changed expected shared lib version from 4.0.0 to 5 in spec file
[platform/upstream/libwebsockets.git] / libwebsockets.spec
1 Name: libwebsockets
2 Version: 1.4
3 Release: 48.gmaster_16fb0132%{?dist}
4 Summary: Websocket Server Library
5
6 Group: System
7 License: GPL
8 URL: http://warmcat.com
9 Source0: %{name}-%{version}.tar.gz
10 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
11
12 BuildRequires: openssl-devel
13 Requires: openssl
14
15 %description
16 Webserver server library
17
18 %package devel
19 Summary: Development files for libwebsockets
20 Group: Development/Libraries
21 Requires: %{name} = %{version}-%{release}
22 Requires: openssl-devel
23
24 %description devel
25 Development files for libwebsockets
26
27 %prep
28 %setup -q
29
30 %build
31 mkdir -p build
32 cd build
33 %cmake ..
34 make
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 cd build
39 make install DESTDIR=$RPM_BUILD_ROOT
40
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 %attr(755,root,root) /usr/bin/libwebsockets-test-server
48 %attr(755,root,root) /usr/bin/libwebsockets-test-server-extpoll
49 %attr(755,root,root) /usr/bin/libwebsockets-test-client
50 %attr(755,root,root) /usr/bin/libwebsockets-test-ping
51 %attr(755,root,root) /usr/bin/libwebsockets-test-echo
52 %attr(755,root,root) /usr/bin/libwebsockets-test-fraggle
53 %attr(755,root,root) 
54 /%{_libdir}/libwebsockets.so.5
55 /%{_libdir}/libwebsockets.so
56 %attr(755,root,root) /usr/share/libwebsockets-test-server
57 %doc
58 %files devel
59 %defattr(-,root,root,-)
60 /usr/include/*
61 %attr(755,root,root)
62 /%{_libdir}/libwebsockets.a
63 /%{_libdir}/pkgconfig/libwebsockets.pc
64
65 %changelog
66