Fix to expose openssl dependency
[platform/upstream/libwebsockets.git] / libwebsockets.spec
1 Name: libwebsockets
2 Version: 2.3.0
3 Release: 1%{?dist}
4 Summary: Websocket Server and Client Library
5
6 Group: System Environment/Libraries
7 License: LGPLv2 with exceptions
8 URL: https://libwebsockets.org
9 Source0: %{name}-%{version}.tar.gz
10 BuildRoot:      %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
11
12 BuildRequires: openssl-devel cmake
13 Requires: openssl
14
15 %description
16 Webserver server and client library
17
18 %package devel
19 Summary: Development files for libwebsockets
20 Group: Development/Libraries
21 Requires: %{name} = %{version}-%{release}
22 Requires: openssl-devel
23
24 %description devel
25 Development files for libwebsockets
26
27 %prep
28 %setup -q
29
30 %build
31 mkdir -p build
32 cd build
33 %cmake ..
34 make
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 cd build
39 make install DESTDIR=$RPM_BUILD_ROOT
40
41 %post -p /sbin/ldconfig
42 %postun -p /sbin/ldconfig
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(-,root,root,-)
49 %attr(755,root,root)
50 /usr/bin/libwebsockets-test-server
51 /usr/bin/libwebsockets-test-server-extpoll
52 /usr/bin/libwebsockets-test-server-pthreads
53 /usr/bin/libwebsockets-test-client
54 /usr/bin/libwebsockets-test-ping
55 /usr/bin/libwebsockets-test-echo
56 /usr/bin/libwebsockets-test-fraggle
57 /usr/bin/libwebsockets-test-fuzxy
58 /%{_libdir}/libwebsockets.so.11
59 /%{_libdir}/libwebsockets.so
60 /%{_libdir}/cmake/libwebsockets/LibwebsocketsConfig.cmake
61 /%{_libdir}/cmake/libwebsockets/LibwebsocketsConfigVersion.cmake
62 /%{_libdir}/cmake/libwebsockets/LibwebsocketsTargets.cmake
63 /%{_libdir}/cmake/libwebsockets/LibwebsocketsTargets-release.cmake
64
65 /usr/share/libwebsockets-test-server
66 %doc
67 %files devel
68 %defattr(-,root,root,-)
69 /usr/include/*
70 %attr(755,root,root)
71 /%{_libdir}/libwebsockets.a
72 /%{_libdir}/pkgconfig/libwebsockets.pc
73
74 %changelog
75 * Fri Jul 28 2017 Andy Green <andy@warmcat.com> 2.3.0-1
76 - MAJOR SONAMEBUMP APICHANGES Upstream 2.3.0 release
77
78 * Mon Mar 06 2017 Andy Green <andy@warmcat.com> 2.2.0-1
79 - MAJOR SONAMEBUMP APICHANGES Upstream 2.2.0 release
80
81 * Thu Oct 06 2016 Andy Green <andy@warmcat.com> 2.1.0-1
82 - MAJOR SONAMEBUMP APICHANGES Upstream 2.1.0 release
83
84 * Thu May 05 2016 Andy Green <andy@warmcat.com> 2.0.0-1
85 - MAJOR SONAMEBUMP APICHANGES Upstream 2.0.0 release
86
87 * Tue Feb 16 2016 Andy Green <andy@warmcat.com> 1.7.0-1
88 - MAJOR SONAMEBUMP APICHANGES Upstream 1.7.0 release
89
90 * Sun Jan 17 2016 Andrew Cooks <acooks@linux.com> 1.6.0-1
91 - Bump version to 1.6.0