resetting manifest requested domain to floor
[platform/upstream/libunistring.git] / packaging / libunistring.spec
1 Name:           libunistring
2 Version:        0.9.3
3 Release:        0
4 License:        LGPL-3.0+ and GPL-3.0+
5 Summary:        GNU Unicode string library
6 Url:            http://www.gnu.org/software/libunistring/
7 Group:          Development/Libraries/C and C++
8 Source:         %{name}-%{version}.tar.bz2
9 Source1001:     libunistring.manifest
10
11 %description
12 This portable C library implements Unicode string types in three flavours:
13 (UTF-8, UTF-16, UTF-32), together with functions for character processing
14 (names, classifications, properties) and functions for string processing
15 (iteration, formatted output, width, word breaks, line breaks, normalization,
16 case folding and regular expressions).
17
18 %package devel
19 Summary:        GNU Unicode string library - development files
20 Group:          Development/Libraries/C and C++
21 Requires:       %{name} = %{version}
22 Requires:       info
23
24 %description devel
25 Development files for programs using libunistring and documentation
26 for UniString library.
27
28 %prep
29 %setup -q
30 cp %{SOURCE1001} .
31
32 %build
33 %configure --disable-static --disable-rpath --docdir=%_docdir/%{name}
34 make %{?_smp_mflags}
35
36 %check
37 %if ! 0%{?qemu_user_space_build}
38 make check %{?_smp_mflags}
39 %endif
40
41 %install
42 echo " " > debugsources.list
43 %make_install DESTDIR=%{buildroot} INSTALL="install -p"
44 rm -f %{buildroot}/%{_infodir}/dir
45 rm -f %{buildroot}/%{_libdir}/libunistring.la
46
47
48 %remove_docs
49
50 %post  -p /sbin/ldconfig
51
52 %postun -p /sbin/ldconfig
53
54
55 %files
56 %manifest %{name}.manifest
57 %license COPYING
58 %defattr(-,root,root)
59 %{_libdir}/libunistring.so.0*
60
61 %files devel
62 %manifest %{name}.manifest
63 %defattr(-,root,root)
64 %{_libdir}/libunistring.so
65 %{_includedir}/unistring
66 %{_includedir}/*.h
67