f6ee983fd81f7f12c6b3a490b2e49c0830661386
[platform/upstream/libunistring.git] / packaging / libunistring.spec
1 Name:           libunistring
2 Version:        0.9.3
3 Release:        0
4 License:        LGPL-3.0+ and GPL-3.0+
5 Summary:        GNU Unicode string library
6 Url:            http://www.gnu.org/software/libunistring/
7 Group:          Development/Libraries/C and C++
8 Source:         %{name}-%{version}.tar.bz2
9
10 %description
11 This portable C library implements Unicode string types in three flavours:
12 (UTF-8, UTF-16, UTF-32), together with functions for character processing
13 (names, classifications, properties) and functions for string processing
14 (iteration, formatted output, width, word breaks, line breaks, normalization,
15 case folding and regular expressions).
16
17 %package devel
18 Summary:        GNU Unicode string library - development files
19 Group:          Development/Libraries/C and C++
20 Requires:       %{name} = %{version}
21 Requires:       info
22
23 %description devel
24 Development files for programs using libunistring and documentation
25 for UniString library.
26
27 %prep
28 %setup -q
29
30 %build
31 %configure --disable-static --disable-rpath --docdir=%_docdir/%{name}
32 make %{?_smp_mflags}
33
34 %check
35 %if ! 0%{?qemu_user_space_build}
36 make check %{?_smp_mflags}
37 %endif
38
39 %install
40 echo " " > debugsources.list
41 %make_install DESTDIR=%{buildroot} INSTALL="install -p"
42 rm -f %{buildroot}/%{_infodir}/dir
43 rm -f %{buildroot}/%{_libdir}/libunistring.la
44
45
46 %remove_docs
47
48 %post  -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52
53 %files
54 %license COPYING
55 %defattr(-,root,root)
56 %{_libdir}/libunistring.so.0*
57
58 %files devel
59 %defattr(-,root,root)
60 %{_libdir}/libunistring.so
61 %{_includedir}/unistring
62 %{_includedir}/*.h
63