keep static
[platform/upstream/libtool.git] / packaging / libtool.spec
1 %define keepstatic 1
2 Name:           libtool
3 BuildRequires:  automake
4 BuildRequires:  gcc-c++
5 BuildRequires:  lzma
6 BuildRequires:  zlib-devel
7 BuildRequires:  makeinfo
8 Requires:       automake > 1.4
9 Requires:       tar
10 Summary:        A Tool to Build Shared Libraries
11 License:        GPL-2.0+
12 Group:          Development/Tools/Building
13 Version:        2.4.2
14 Release:        0
15 Requires:       libltdl = %{version}
16 Url:            http://www.gnu.org/software/libtool/
17 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
18 Source2:        baselibs.conf
19 Source3:        libtool-rpmlintrc
20 Provides:       libltdl-devel
21 # fedora name
22 Provides:       libtool-ltdl-devel
23
24 %description
25 GNU libtool is a set of shell scripts to automatically configure UNIX
26 architectures to build shared libraries in a generic fashion.
27
28 %package -n libltdl
29 Summary:        Libtool Runtime Library
30 Group:          Development/Libraries/C and C++
31
32 %description -n libltdl
33 Library needed by programs that use the ltdl interface of GNU libtool.
34
35 %prep
36 %setup -q -n libtool-%{version}
37
38 %build
39 ./configure CFLAGS="$RPM_OPT_FLAGS" \
40    --prefix=/usr --infodir=%{_infodir} --libdir=%{_libdir}
41 # force rebuild with non-broken makeinfo
42 rm -f doc/libtool.info
43 make %{?_smp_mflags}
44
45
46 %install
47 %make_install
48
49 %post -n libltdl -p /sbin/ldconfig
50
51 %postun -n libltdl -p /sbin/ldconfig
52
53 %files
54 %defattr(-, root, root)
55 /usr/bin/libtool
56 /usr/bin/libtoolize
57 /usr/include/libltdl
58 /usr/include/ltdl.h
59 %{_libdir}/libltdl.a
60 %attr(644, root, root) %{_libdir}/libltdl.la
61 %{_libdir}/libltdl.so
62 /usr/share/aclocal/*.m4
63 %doc %{_infodir}/libtool.info*
64 %doc %{_mandir}/man1/libtool.1.gz
65 %doc %{_mandir}/man1/libtoolize.1.gz
66 /usr/share/libtool
67
68 %files -n libltdl
69 %defattr(-, root, root)
70 %{_libdir}/libltdl.so.*
71
72 %changelog