9dfffb1c48a8d29bdd60d24e6683f1fc7572bf0e
[platform/upstream/libtool.git] / packaging / libtool.spec
1 %define keepstatic 1
2 Name:           libtool
3 BuildRequires:  automake
4 BuildRequires:  gcc-c++
5 BuildRequires:  lzma
6 BuildRequires:  zlib-devel
7 BuildRequires:  makeinfo
8 Requires:       automake > 1.4
9 Requires:       tar
10 Summary:        A Tool to Build Shared Libraries
11 License:        GPL-2.0+
12 Group:          Development/Tools
13 Version:        2.4.2
14 Release:        0
15 Requires:       libltdl = %{version}
16 Url:            http://www.gnu.org/software/libtool/
17 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
18 Source2:        baselibs.conf
19 Source3:        libtool-rpmlintrc
20 Source1001:     libtool.manifest
21 Provides:       libltdl-devel
22 # fedora name
23 Provides:       libtool-ltdl-devel
24
25 %description
26 GNU libtool is a set of shell scripts to automatically configure UNIX
27 architectures to build shared libraries in a generic fashion.
28
29 %package -n libltdl
30 Summary:        Libtool Runtime Library
31 Group:          System/Libraries
32
33 %description -n libltdl
34 Library needed by programs that use the ltdl interface of GNU libtool.
35
36 %prep
37 %setup -q -n libtool-%{version}
38 cp %{SOURCE1001} .
39
40 %build
41 ./configure CFLAGS="$RPM_OPT_FLAGS" \
42    --prefix=/usr --infodir=%{_infodir} --libdir=%{_libdir}
43 # force rebuild with non-broken makeinfo
44 rm -f doc/libtool.info
45 make %{?_smp_mflags}
46
47
48 %install
49 make install DESTDIR=$RPM_BUILD_ROOT
50
51 %post -n libltdl -p /sbin/ldconfig
52
53 %postun -n libltdl -p /sbin/ldconfig
54
55 %files
56 %manifest %{name}.manifest
57 %defattr(-, root, root)
58 %license COPYING
59 /usr/bin/libtool
60 /usr/bin/libtoolize
61 /usr/include/libltdl
62 /usr/include/ltdl.h
63 %{_libdir}/libltdl.a
64 %attr(644, root, root) %{_libdir}/libltdl.la
65 %{_libdir}/libltdl.so
66 /usr/share/aclocal/*.m4
67 %doc %{_infodir}/libtool.info*
68 %doc %{_mandir}/man1/libtool.1.gz
69 %doc %{_mandir}/man1/libtoolize.1.gz
70 /usr/share/libtool
71
72 %files -n libltdl
73 %manifest %{name}.manifest
74 %defattr(-, root, root)
75 %{_libdir}/libltdl.so.*
76
77 %changelog