3fcef07b128f44cf09fb9d7804c2673d716b04de
[platform/upstream/libtool.git] / packaging / libtool.spec
1 Name:           libtool
2 BuildRequires:  automake
3 BuildRequires:  gcc-c++
4 BuildRequires:  lzma
5 BuildRequires:  zlib-devel
6 BuildRequires:  makeinfo
7 Requires:       automake > 1.4
8 Requires:       tar
9 Summary:        A Tool to Build Shared Libraries
10 License:        GPL-2.0+
11 Group:          Development/Tools/Building
12 Version:        2.4.2
13 Release:        0
14 Requires:       libltdl = %{version}
15 Url:            http://www.gnu.org/software/libtool/
16 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
17 Source2:        baselibs.conf
18 Source3:        libtool-rpmlintrc
19 Provides:       libltdl-devel
20 # fedora name
21 Provides:       libtool-ltdl-devel
22
23 %description
24 GNU libtool is a set of shell scripts to automatically configure UNIX
25 architectures to build shared libraries in a generic fashion.
26
27 %package -n libltdl
28 Summary:        Libtool Runtime Library
29 Group:          Development/Libraries/C and C++
30
31 %description -n libltdl
32 Library needed by programs that use the ltdl interface of GNU libtool.
33
34 %prep
35 %setup -q -n libtool-%{version}
36
37 %build
38 ./configure CFLAGS="$RPM_OPT_FLAGS" \
39    --prefix=/usr --infodir=%{_infodir} --libdir=%{_libdir}
40 # force rebuild with non-broken makeinfo
41 rm -f doc/libtool.info
42 make %{?_smp_mflags}
43
44
45 %install
46 %make_install
47
48 %post -n libltdl -p /sbin/ldconfig
49
50 %postun -n libltdl -p /sbin/ldconfig
51
52 %files
53 %defattr(-, root, root)
54 /usr/bin/libtool
55 /usr/bin/libtoolize
56 /usr/include/libltdl
57 /usr/include/ltdl.h
58 %{_libdir}/libltdl.a
59 %attr(644, root, root) %{_libdir}/libltdl.la
60 %{_libdir}/libltdl.so
61 /usr/share/aclocal/*.m4
62 %doc %{_infodir}/libtool.info*
63 %doc %{_mandir}/man1/libtool.1.gz
64 %doc %{_mandir}/man1/libtoolize.1.gz
65 /usr/share/libtool
66
67 %files -n libltdl
68 %defattr(-, root, root)
69 %{_libdir}/libltdl.so.*
70
71 %changelog