Aarch64 build fix
[platform/upstream/libtool.git] / packaging / libtool.spec
1 %define keepstatic 1
2 Name:           libtool
3 BuildRequires:  automake
4 BuildRequires:  gcc-c++
5 BuildRequires:  lzma
6 BuildRequires:  zlib-devel
7 BuildRequires:  makeinfo
8 Requires:       automake > 1.4
9 Requires:       tar
10 Summary:        A Tool to Build Shared Libraries
11 License:        GPL-2.0+
12 Group:          Development/Tools
13 Version:        2.4.2
14 Release:        0
15 Requires:       libltdl = %{version}
16 Url:            http://www.gnu.org/software/libtool/
17 Source:         http://ftp.gnu.org/gnu/libtool/libtool-%{version}.tar.gz
18 Source2:        baselibs.conf
19 Source3:        libtool-rpmlintrc
20 Source1001:     libtool.manifest
21 Provides:       libltdl-devel
22 # fedora name
23 Provides:       libtool-ltdl-devel
24
25 %description
26 GNU libtool is a set of shell scripts to automatically configure UNIX
27 architectures to build shared libraries in a generic fashion.
28
29 %package -n libltdl
30 Summary:        Libtool Runtime Library
31 Group:          System/Libraries
32
33 %description -n libltdl
34 Library needed by programs that use the ltdl interface of GNU libtool.
35
36 %prep
37 %setup -q -n libtool-%{version}
38 cp %{SOURCE1001} .
39
40 %build
41 %configure
42 # force rebuild with non-broken makeinfo
43 rm -f doc/libtool.info
44 make %{?_smp_mflags}
45
46
47 %install
48 make install DESTDIR=$RPM_BUILD_ROOT
49
50 %post -n libltdl -p /sbin/ldconfig
51
52 %postun -n libltdl -p /sbin/ldconfig
53
54 %files
55 %manifest %{name}.manifest
56 %defattr(-, root, root)
57 %license COPYING
58 /usr/bin/libtool
59 /usr/bin/libtoolize
60 /usr/include/libltdl
61 /usr/include/ltdl.h
62 %{_libdir}/libltdl.a
63 %attr(644, root, root) %{_libdir}/libltdl.la
64 %{_libdir}/libltdl.so
65 /usr/share/aclocal/*.m4
66 %doc %{_infodir}/libtool.info*
67 %doc %{_mandir}/man1/libtool.1.gz
68 %doc %{_mandir}/man1/libtoolize.1.gz
69 /usr/share/libtool
70
71 %files -n libltdl
72 %manifest %{name}.manifest
73 %defattr(-, root, root)
74 %{_libdir}/libltdl.so.*
75
76 %changelog