spec: Use %license macro to copy license
[platform/upstream/libtheora.git] / libtheora.spec
1 Name:           libtheora
2 Version:        1.1.1
3 Release:        0.xiph.0.4.alpha5
4 Summary:        The Theora Video Compression Codec.
5
6 Group:          System Environment/Libraries
7 License:        BSD
8 URL:            http://www.theora.org/
9 Vendor:         Xiph.org Foundation <team@xiph.org>
10 Source:         http://downloads.xiph.org/releases/theora/%{name}-%{version}.tar.gz
11 BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13 BuildRequires:  libogg-devel >= 2:1.1
14 BuildRequires:  libvorbis-devel >= 1:1.0.1
15 BuildRequires:  SDL-devel
16
17 # this needs to be explicit since vorbis's .so versioning didn't get bumped
18 # when going from 1.0 to 1.0.1
19 Requires:       libvorbis >= 1:1.0.1
20
21 %description
22 Theora is Xiph.Org's first publicly released video codec, intended
23 for use within the Ogg's project's Ogg multimedia streaming system.
24 Theora is derived directly from On2's VP3 codec; Currently the two are
25 nearly identical, varying only in encapsulating decoder tables in the
26 bitstream headers, but Theora will make use of this extra freedom
27 in the future to improve over what is possible with VP3.
28
29 %package devel
30 Summary:        Development tools for Theora applications.
31 Group:          Development/Libraries
32 Requires:       %{name} = %{version}-%{release}
33 Requires:       libogg-devel >= 2:1.1
34
35 %description devel
36 The libtheora-devel package contains the header files and documentation
37 needed to develop applications with Ogg Theora.
38
39 %prep
40 %setup -q -n %{name}-%{version}
41
42 %build
43 %configure --enable-shared
44 make
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 # make sure our temp doc build dir is removed
49 rm -rf $(pwd)/__docs
50
51 %makeinstall docdir=$(pwd)/__docs
52
53 find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
54
55 %clean 
56 rm -rf $RPM_BUILD_ROOT
57
58 %post -p /sbin/ldconfig
59
60 %postun -p /sbin/ldconfig
61
62 %files
63 %defattr(-,root,root)
64 %doc COPYING README
65 %{_libdir}/libtheora.so.*
66
67 %files devel
68 %defattr(-,root,root,-)
69 %doc __docs/*
70 %{_libdir}/libtheora.a
71 %{_libdir}/libtheora.so
72 %dir %{_includedir}/theora
73 %{_includedir}/theora/codec.h
74 %{_includedir}/theora/theora.h
75 %{_includedir}/theora/theoradec.h
76 %{_libdir}/pkgconfig/theora.pc
77
78 %changelog
79 * Sat Aug 20 2005 Ralph Giles <giles at xiph.org>
80 - updated version for 1.0alpha5 release
81 * Thu Jun 10 2004 Thomas Vander Stichele <thomas at apestaart dot org>
82 - transported fedora.us spec file