f071645709e0d3401f798300d09dfeee48c017d4
[platform/upstream/libnl2.git] / packaging / libnl2.spec
1 Name:       libnl2
2 Summary:    Library for netlink sockets
3 Version:    2.0
4 Release:    2
5 Group:      System/Network
6 License:    LGPL-2.1+
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001:     libnl2.manifest
9 BuildRequires:  bison
10 BuildRequires:  flex
11
12 %description
13 This is a library for applications dealing with netlink sockets.
14 The library provides an interface for raw netlink messaging and various
15 netlink family specific interfaces.
16
17 %package devel
18 Summary:    Development library and headers for libnl2
19 Group:      Development/Libraries
20 Requires:   %{name} = %{version}-%{release}
21
22 %description devel
23 This is a library for applications dealing with netlink sockets.
24 The library provides an interface for raw netlink messaging and various
25 netlink family specific interfaces.
26 This package contains all files that are needed to build applications using
27 libnl2.
28
29 %prep
30 %setup -q
31 cp %{SOURCE1001} .
32
33
34 %build
35 %autogen.sh
36 %configure 
37
38 make -j1
39
40 %install
41 %make_install
42
43 mkdir -p %{buildroot}/usr/share/license
44 cp %{_builddir}/%{buildsubdir}/COPYING %{buildroot}/usr/share/license/%{name}
45 rm -f %{buildroot}/etc/libnl/pktloc
46
47
48 %post -p /sbin/ldconfig
49
50 %postun -p /sbin/ldconfig
51
52 %files
53 %manifest %{name}.manifest
54 %defattr(-,root,root,-)
55 %{_libdir}/libnl*.so.*
56 /usr/share/license/%{name}
57
58 %files devel
59 %manifest %{name}.manifest
60 %defattr(-,root,root,-)
61 %{_includedir}/*
62 %{_libdir}/pkgconfig/*
63 %{_libdir}/libnl*.so