run %configure to install correctly
[platform/upstream/libnl2.git] / packaging / libnl2.spec
1 Name:       libnl2
2 Summary:    Library for netlink sockets
3 Version:    2.0
4 Release:    2
5 Group:      System/Network
6 License:    LGPL-2.1
7 Source0:    %{name}-%{version}.tar.gz
8 BuildRequires:  bison
9 BuildRequires:  flex
10
11 %description
12 This is a library for applications dealing with netlink sockets.
13 The library provides an interface for raw netlink messaging and various
14 netlink family specific interfaces.
15
16 %package devel
17 Summary:    Development library and headers for libnl2
18 Group:      Development/Libraries
19 Requires:   %{name} = %{version}-%{release}
20
21 %description devel
22 This is a library for applications dealing with netlink sockets.
23 The library provides an interface for raw netlink messaging and various
24 netlink family specific interfaces.
25 This package contains all files that are needed to build applications using
26 libnl2.
27
28 %prep
29 %setup -q
30
31
32 %build
33 %autogen.sh
34 %configure 
35
36 make -j1
37
38 %install
39 %make_install
40 rm -f %{buildroot}/etc/libnl/pktloc
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46 %files
47 %defattr(-,root,root,-)
48 %license COPYING
49 %{_libdir}/libnl*.so.*
50
51 %files devel
52 %defattr(-,root,root,-)
53 %{_includedir}/*
54 %{_libdir}/pkgconfig/*
55 %{_libdir}/libnl*.so