2248f10ca8a8df234c063a20916c301de659ee2a
[platform/upstream/libnl2.git] / packaging / libnl2.spec
1 #sbs-git:slp/pkgs/l/libnl2
2
3 Name:       libnl2
4 Summary:    Library for netlink sockets
5 Version:    2.0
6 Release:    2
7 Group:      System/Network
8 License:    GNU LESSER GENERAL PUBLIC LICENSE Version 2.1
9 Source0:    %{name}-%{version}.tar.gz
10 BuildRequires:  bison
11 BuildRequires:  flex
12
13 %description
14 This is a library for applications dealing with netlink sockets.
15 The library provides an interface for raw netlink messaging and various
16 netlink family specific interfaces.
17
18 %package devel
19 Summary:    Development library and headers for libnl2
20 Group:      Development/Libraries
21 Requires:   %{name} = %{version}-%{release}
22
23 %description devel
24 This is a library for applications dealing with netlink sockets.
25 The library provides an interface for raw netlink messaging and various
26 netlink family specific interfaces.
27 This package contains all files that are needed to build applications using
28 libnl2.
29
30 %prep
31 %setup -q
32
33 ./autogen.sh
34
35 %build
36 CFLAGS="$RPM_OPT_FLAGS" \
37         ./configure \
38         --prefix=/usr
39
40 #No much jobs, make sure -j1
41 #make %{?jobs:-j%jobs}
42 make -j1
43
44 %install
45 rm -rf %{buildroot}
46 %make_install
47
48 rm %{buildroot}/usr/etc/libnl/pktloc
49
50 %files
51 %defattr(-,root,root,-)
52 %{_libdir}/libnl*.so.*
53
54 %files devel
55 %defattr(-,root,root,-)
56 %{_includedir}/*
57 %{_libdir}/pkgconfig/*
58 %{_libdir}/libnl*.so