Use %license macro to copy license file.
[platform/upstream/libnfnetlink.git] / packaging / libnfnetlink.spec
1 Name:           libnfnetlink
2 %define libsoname       %{name}
3 Version:        1.0.1
4 Release:        2
5 License:        GPL-2.0
6 Url:            http://netfilter.org/projects/libnfnetlink/
7 Group:          Productivity/Networking/Security
8
9 Summary:        Low-level library for Netfilter-related kernel/userspace communication
10 Source:         %{name}-%{version}.tar.bz2
11 Source2:        baselibs.conf
12 Source1001:     libnfnetlink.manifest
13 BuildRequires:  autoconf
14 BuildRequires:  automake >= 1.6
15 BuildRequires:  libtool
16 BuildRequires:  pkgconfig >= 0.23
17 BuildRequires:  xz
18
19 %description
20 libnfnetlink is the low-level library for netfilter related
21 kernel/userspace communication. It provides a generic messaging
22 infrastructure for in-kernel netfilter subsystems (such as
23 nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their
24 respective users and/or management tools in userspace.
25
26 This library is not meant as a public API for application developers.
27 It is only used by other netfilter.org projects, such as
28 libnetfilter_log, libnetfilter_queue or libnetfilter_conntrack.
29
30 %package devel
31 Summary:        Low-level library for Netfilter-related kernel/userspace communication
32 Group:          Development/Libraries/C and C++
33 Requires:       %libsoname = %{version}
34
35 %description devel
36 libnfnetlink is the low-level library for netfilter related
37 kernel/userspace communication. It provides a generic messaging
38 infrastructure for in-kernel netfilter subsystems (such as
39 nfnetlink_log, nfnetlink_queue, nfnetlink_conntrack) and their
40 respective users and/or management tools in userspace.
41
42 This library is not meant as a public API for application developers.
43 It is only used by other netfilter.org projects, such as
44 libnetfilter_log, libnetfilter_queue or libnetfilter_conntrack.
45
46 %prep
47 %setup -q
48 cp %{SOURCE1001} .
49
50 %build
51 %configure --disable-static --includedir=%{_includedir}/%{name}-%{version}
52 make %{?_smp_mflags}
53
54 %install
55 %make_install
56
57 %post  -p /sbin/ldconfig
58
59 %postun  -p /sbin/ldconfig
60
61 %files
62 %manifest %{name}.manifest
63 %license COPYING
64 %defattr(-,root,root)
65 %doc COPYING
66 %{_libdir}/libnfnetlink.so.*
67
68 %files devel
69 %manifest %{name}.manifest
70 %defattr(-,root,root)
71 %{_includedir}/libnfnetlink*
72 %{_libdir}/libnfnetlink.so
73 %{_libdir}/pkgconfig/libnfnetlink.pc
74
75 %changelog