resetting manifest requested domain to floor
[platform/upstream/libjpeg6.git] / packaging / libjpeg6.spec
1 Name:           libjpeg6
2 Version:        6b
3 Release:        0
4 License:        IJG
5 Summary:        A library for manipulating JPEG image format files
6 URL:            http://www.ijg.org/
7 Group:          System/Libraries
8 Source:         jpegsrc.v%{version}.tar.gz
9 Source1001:     libjpeg6.manifest
10 BuildRequires:  autoconf
11 BuildRequires:  libtool
12
13 %description
14 The libjpeg package contains a library of functions for manipulating
15 JPEG images, as well as simple client programs for accessing the
16 libjpeg functions.  Libjpeg client programs include cjpeg, djpeg,
17 jpegtran, rdjpgcom and wrjpgcom.  Cjpeg compresses an image file into
18 JPEG format.  Djpeg decompresses a JPEG file into a regular image
19 file.  Jpegtran can perform various useful transformations on JPEG
20 files.  Rdjpgcom displays any text comments included in a JPEG file.
21 Wrjpgcom inserts text comments into a JPEG file.
22
23 %package devel
24 Summary:        Development tools for programs which will use the libjpeg library
25 Group:          Development/Libraries
26 Requires:       libjpeg6 = %{version}-%{release}
27 Conflicts:      libjpeg-turbo
28 Conflicts:      libjpeg-devel
29
30 %description devel
31 The libjpeg-devel package includes the header files and documentation
32 necessary for developing programs which will manipulate JPEG files using
33 the libjpeg library.
34
35 If you are going to develop programs which will manipulate JPEG images,
36 you should install libjpeg-devel.  You'll also need to have the libjpeg
37 package installed.
38
39
40 %prep
41 %setup -q -n jpeg-%{version}
42 cp %{SOURCE1001} .
43
44 # libjpeg 6b includes a horribly obsolete version of libtool.
45 # Blow it away and replace with build system's version.
46 rm -f ltmain.sh ltconfig aclocal.m4
47
48 %build
49 %reconfigure --enable-shared --disable-static
50
51 make libdir=%{_libdir} %{?_smp_mflags}
52
53 %check
54 LD_LIBRARY_PATH=$PWD:$LD_LIBRARY_PATH make test libdir=%{_libdir}
55
56 %install
57 mkdir -p %{buildroot}%{_bindir}
58 mkdir -p %{buildroot}%{_includedir}
59 mkdir -p %{buildroot}%{_libdir}
60 mkdir -p %{buildroot}%{_mandir}/man1
61
62 # The make_install macro doesn't work here...
63 %makeinstall
64
65 # Work around the broken makefiles...
66 mv %{buildroot}%{_mandir}/*.1 %{buildroot}%{_mandir}/man1
67 rm -f %{buildroot}%{_libdir}/libjpeg.la
68
69
70 %post -p /sbin/ldconfig
71
72 %postun -p /sbin/ldconfig
73
74
75 %docs_package
76
77 %files
78 %manifest %{name}.manifest
79 %{_libdir}/libjpeg.so.*
80
81 %files devel
82 %manifest %{name}.manifest
83 %{_bindir}/*
84 %{_includedir}/*.h
85 %{_libdir}/*.so