bump to 1.0.0 and clean up spec file
[platform/upstream/libical.git] / packaging / libical.spec
1 Name:           libical
2 Version:        1.0.0
3 Release:        0
4 Url:            https://github.com/libical/libical/archive/v1.0.0.tar.gz
5 Summary:        An Implementation of Basic iCAL Protocols
6 License:        MPL-1.1 or LGPL-2.1
7 Group:          Development/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source2:        baselibs.conf
10 Source1001:     %{name}.manifest
11 BuildRequires:  db4-devel
12 BuildRequires:  libtool
13 BuildRequires:  pkg-config
14 BuildRequires:  python-devel
15
16 %description
17 Libical is an open source implementation of the IETF's iCalendar
18 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
19 parses iCal components and provides a C API for manipulating the
20 component properties, parameters, and subcomponents.
21
22 %package devel
23 Summary:        An implementation of basic iCAL protocols
24 Group:          Development/Libraries
25 Requires:       %{name} = %{version}
26
27 %description devel
28 Libical is an Open Source implementation of the IETF's iCalendar
29 Calendaring and Scheduling protocols. (RFC 2445, 2446, and 2447). It
30 parses iCal components and provides a C API for manipulating the
31 component properties, parameters, and subcomponents.
32
33 %package docs
34 Summary:        An Implementation of Basic iCAL Protocols
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}
37
38 %description docs
39 Libical is an open source implementation of the IETF's iCalendar
40 calendaring and scheduling protocols (RFC 2445, 2446, and 2447). It
41 parses iCal components and provides a C API for manipulating the
42 component properties, parameters, and subcomponents.
43
44 %prep
45 %setup -q
46 cp %{SOURCE1001} .
47
48 %build
49 # triger autoreconf since the 0.46 tarball is missing autotools bootstrap files
50 autoreconf -f -i
51 %{configure} \
52         --with-bdb4 \
53         --with-bdb4-dir=%{_prefix} \
54         --without-builtintz \
55         --enable-shared \
56         --disable-static
57 %{__make} %{?_smp_mflags}
58
59 %install
60 %make_install
61 %{__rm} doc/Makefile*
62 %{__rm} -rf examples/.deps
63 %{__rm} -rf examples/.libs
64 %{__rm} examples/*.o
65 %{__rm} examples/doesnothing
66 %{__rm} scripts/Makefile*
67 %{__sed} -i -e '1s,.*,#!/usr/bin/perl,' scripts/mkneticali.pl
68
69 %post  -p /sbin/ldconfig
70
71 %postun -p /sbin/ldconfig
72
73 %files 
74 %manifest %{name}.manifest
75 %defattr(-,root,root)
76 %license COPYING
77 %{_libdir}/*.so.*
78
79 %files devel
80 %manifest %{name}.manifest
81 %defattr(-,root,root)
82 %{_libdir}/*.so
83 %{_libdir}/pkgconfig/libical.pc
84 %{_includedir}/ical.h
85 %{_includedir}/libical
86
87 %files docs
88 %manifest %{name}.manifest
89 %defattr(-,root,root)
90 %doc doc examples scripts
91