39ea9eb73775a3f45ffb751ce08d360d379907d9
[platform/upstream/libexif.git] / packaging / libexif.spec
1 Name:           libexif
2 Version:        0.6.21
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        An EXIF Tag Parsing Library for Digital Cameras
6 Url:            http://libexif.sourceforge.net
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.bz2
9 Source1:        baselibs.conf
10 Source1001:     libexif.manifest
11 BuildRequires:  doxygen
12 BuildRequires:  pkg-config
13 BuildRequires:  gettext-tools
14
15 %define debug_package_requires %{name} = %{version}-%{release}
16
17 %description
18 This library is used to parse EXIF information from JPEGs created by
19 digital cameras.
20
21 %package devel
22 Summary:        An EXIF Tag Parsing Library for Digital Cameras (Development files)
23 Group:          Development/Libraries/C and C++
24 Requires:       %{name} = %{version}
25 Requires:       glibc-devel
26
27 %description devel
28 This library is used to parse EXIF information from JPEGs created by
29 digital cameras.
30
31 %prep
32 %setup -q
33 cp %{SOURCE1001} .
34
35 %build
36 %reconfigure --with-pic \
37         --disable-static \
38         --with-doc-dir=%{_docdir}/%{name}
39 make 
40 ### %{?_smp_mflags}
41
42 %check
43 make check
44
45 %install
46 %make_install
47 %find_lang %{name}-12
48
49 %post  -p /sbin/ldconfig
50
51 %postun  -p /sbin/ldconfig
52
53 %files -f %{name}-12.lang
54 %manifest %{name}.manifest
55 %license COPYING
56 %defattr(-,root,root)
57 %{_libdir}/*.so.*
58
59 %files devel
60 %manifest %{name}.manifest
61 %defattr(-,root,root)
62 %doc %{_docdir}/%{name}
63 %{_libdir}/*.so
64 %{_libdir}/pkgconfig/*.pc
65 %{_includedir}/*
66
67 %changelog