resetting manifest requested domain to floor
[platform/upstream/libelf0.git] / packaging / libelf0.spec
1 Name:           libelf0
2 Version:        0.8.13
3 Release:        0
4 License:        LGPL-2.1+
5 Summary:        An ELF Object File Access Library
6 Url:            http://www.mr511.de/software/
7 Group:          System/Libraries
8 Source:         libelf-%{version}.tar.bz2
9 Source2:        baselibs.conf
10 Source1001:     libelf0.manifest
11 BuildRequires:  pkgconfig
12 BuildRoot:      %{_tmppath}/%{name}-%{version}-build
13
14 %description
15 The libelf package contains a library for accessing ELF object files.
16 Libelf allows you to access the internals of the ELF object file
17 format, so you can see the different sections of an ELF file.
18
19 %package devel
20 Summary:        Include Files and Libraries mandatory for Development
21 Group:          Development/Libraries/C and C++
22 Requires:       %{name} = %{version}
23 Requires:       glibc-devel,
24 Conflicts:      libelf1-devel
25
26 %description devel
27 This package contains all necessary include files and libraries needed
28 to develop applications that require these.
29
30 %prep
31 %setup -q -n libelf-%{version}
32 cp %{SOURCE1001} .
33
34 %build
35 %configure --disable-nls
36 make %{?_smp_mflags}
37
38 %install
39 make install instroot=%{buildroot}
40 # remove the wrapper includes
41 rm -f %{buildroot}%{_includedir}/*.h
42 # remove unneeded *.la and *.a files
43 rm -f %{buildroot}%{_libdir}/*.la
44
45 %post -p /sbin/ldconfig
46
47 %postun -p /sbin/ldconfig
48
49 %files
50 %manifest %{name}.manifest
51 %defattr(-,root,root)
52 %license COPYING.LIB 
53 %{_libdir}/libelf.so.*
54
55 %files devel
56 %manifest %{name}.manifest
57 %defattr(-,root,root)
58 %{_libdir}/libelf.so
59 %{_libdir}/libelf.a
60 %{_libdir}/pkgconfig/libelf.pc
61 %{_includedir}/libelf
62
63 %changelog