resetting manifest requested domain to floor
[platform/upstream/libasyncns.git] / packaging / libasyncns.spec
1 Name:           libasyncns
2 Version:        0.8
3 Release:        1
4 License:        LGPL-2.1+
5 Summary:        A C library for executing name service queries asynchronously
6 URL:            http://0pointer.de/lennart/projects/libasyncns
7 Group:          System/Libraries
8 Source:         %{name}-%{version}.tar.gz
9 Source1001:     libasyncns.manifest
10
11 %description
12 Libasyncns is a C library for executing name service queries
13 asynchronously. It is an asynchronous wrapper around getaddrinfo(3),
14 getnameinfo(3), res_query(3) and res_search(3) from libc and libresolv.
15
16 %package devel
17 Summary:        libasyncns development package
18 Group:          Development/Libraries
19 Requires:       %{name} = %{version}
20
21 %description devel
22 Development package for libasyncns, a C library for executing name
23 service queries asynchronously. It is an asynchronous wrapper around
24 getaddrinfo(3), getnameinfo(3), res_query(3) and res_search(3) from libc
25 and libresolv.
26
27 %prep
28 %setup -q
29 cp %{SOURCE1001} .
30
31 %build
32 %configure
33
34 make %{?_smp_mflags}
35
36 %install
37 %make_install
38
39 rm -rf %{buildroot}%{_datadir}/doc
40
41
42 %post -p /sbin/ldconfig
43
44 %postun -p /sbin/ldconfig
45
46
47 %files
48 %manifest %{name}.manifest
49 %{_libdir}/libasyncns.so.*
50
51 %files devel
52 %manifest %{name}.manifest
53 %{_includedir}/asyncns.h
54 %{_libdir}/libasyncns.so
55 %{_libdir}/pkgconfig/libasyncns.pc