Bump to 0.3.113
[platform/upstream/libaio.git] / libaio.spec
1 Name: libaio
2 Version: 0.3.113
3 Release: 1
4 Summary: Linux-native asynchronous I/O access library
5 License: LGPL
6 Group:  System Environment/Libraries
7 Source: %{name}-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-root
9 # Fix ExclusiveArch as we implement this functionality on more architectures
10 ExclusiveArch: i386 x86_64 ia64 s390 s390x ppc ppc64 ppc64pseries ppc64iseries alpha alphaev6 %{arm} loongarch64
11
12 %description
13 The Linux-native asynchronous I/O facility ("async I/O", or "aio") has a
14 richer API and capability set than the simple POSIX async I/O facility.
15 This library, libaio, provides the Linux-native API for async I/O.
16 The POSIX async I/O facility requires this library in order to provide
17 kernel-accelerated async I/O capabilities, as do applications which
18 require the Linux-native async I/O API.
19
20 %package devel
21 Summary: Development files for Linux-native asynchronous I/O access
22 Group: Development/System
23 Requires: libaio
24 Provides: libaio.so.1
25
26 %description devel
27 This package provides header files to include and libraries to link with
28 for the Linux-native asynchronous I/O facility ("async I/O", or "aio").
29
30 %prep
31 %setup
32
33 %build
34 make
35
36 %install
37 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
38
39 make install DESTDIR=$RPM_BUILD_ROOT prefix=/usr libdir=/%{_libdir}
40
41 %clean
42 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
43
44 %post -p /sbin/ldconfig
45
46 %postun -p /sbin/ldconfig
47
48 %files
49 %defattr(-,root,root)
50 %attr(0755,root,root) %{_libdir}/libaio.so.*
51 %doc COPYING TODO
52
53 %files devel
54 %defattr(-,root,root)
55 %attr(0644,root,root) %{_includedir}/*
56 %attr(0755,root,root) %{_libdir}/libaio.so
57 %attr(0644,root,root) %{_libdir}/libaio.a
58
59 %changelog
60 * Mon Mar 28 2022 Jeff Moyer <jmoyer@redhat.com> - 0.3.113-1
61 - Fix padding in vector and sockaddr structures on 32 bit (Brett Holman)
62 - Add a test case for missed poll events (Eric Biggers)
63 - Add loongarch support (Yehui Ren)
64 - man page cleanup and fixes (Guillem Jover)
65 - assorted test harness fixess (Guillem Jover, Jeff Moyer)
66
67 * Mon Oct 22 2018 Jeff Moyer <jmoyer@redhat.com> - 0.3.112-1
68 - Add async poll support (Christoph Hellwig)
69 - Use canonical DESTDIR= environment variable (Thomas Petazzoni)
70 - Add ability to disable building the shared library (Thomas Petazzoni)
71
72 * Tue Mar  6 2018 Jeff Moyer <jmoyer@redhat.com> - 0.3.111-1
73 - Add two new tests to the test harness (Jeff Moyer)
74 - Generic arch dectection for padding defines (Nathan Rossi)
75 - harness: don't hardcode page size (Jeff Moyer)
76 - harness: add a test case for mremap (Jeff Moyer)
77 - libaio: harness: fix build errors due to attribute warn_unused_result (Mauricio Faria de Oliveira)
78 - libaio: harness: fix build error due to linker search order (Mauricio Faria de Oliveira)
79 - harness: add test for allocating aio-max-nr ioctxs (Jeff Moyer)
80 - Add support for preadv2/pwritev2 (Jeff Moyer)
81 - syscall-generic: don't overwrite errno (Jeff Moyer)
82 - syscall: get rid of custom syscall implementation (Jeff Moyer)
83 - Change syscall-arm64.h to syscall-generic.h (Icenowy Zheng)
84 - Use generic syscall number schema for RISC-V (Icenowy Zheng)
85 - Add endian detection (LE) and bit width detection (32/64) for RISC-V (Icenowy Zheng)
86 - Makefile: convert tag and archive targets to git (Jeff Moyer)
87
88 * Fri Jul  5 2013 Jeff Moyer <jmoyer@redhat.com> - 0.3.110-1
89 - Add suport for sparc and arm64 (Mike Frysinger and Jeff Moyer)
90 - Add generic syscall fallbacks (Mike Frysinger)
91 - Update man pages (Jeff Moyer and Cyril Hrubis)
92 - Build system fixes (Mike Frysinger)
93
94 * Tue Jun  9 2009 Jeff Moyer <jmoyer@redhat.com> - 0.3.108-1
95 - add ARM architecture support (grabbed from Debian arches tree)
96 - replace check of __i386__ with __LP64__ in test harness (Jeff Moyer)
97 - change the .spec's copyright tag to license
98
99 * Wed Jan  9 2008 Jeff Moyer <jmoyer@redhat.com> - 0.3.107-1
100 - Fix the test harness (Rusty Russell)
101 - Add eventfd support (Rusty Russell)
102
103 * Tue Jan  3 2006 Jeff Moyer <jmoyer@redhat.com> - 0.3.106-1
104 - Add a .proc directive for the ia64_aio_raw_syscall macro.  This sounds a lot
105   like the previous entry, but that one fixed the __ia64_raw_syscall macro,
106   located in syscall-ia64.h.  This macro is in raw_syscall.c, which pretty much
107   only exists for ia64.  This bug prevented the package from building with
108   newer version of gcc.
109
110 * Mon Aug  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.105-1
111 - Add a .proc directive for the ia64 raw syscall macro.
112
113 * Fri Apr  1 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.104-1
114 - Add Alpha architecture support.  (Sergey Tikhonov <tsv@solvo.ru>)
115
116 * Tue Jan 25 2005 Jeff Moyer <jmoyer@redhat.com> - 0.3.103-1
117 - Fix SONAME breakage.  In changing file names around, I also changed the 
118   SONAME, which is a no no.
119
120 * Thu Oct 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.102-1
121 - S390 asm had a bug; I forgot to update the clobber list.  Lucky for me,
122   newer compilers complain about such things.
123 - Also update the s390 asm to look more like the new kernel variants.
124
125 * Wed Oct 13 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.101-1
126 - Revert syscall return values to be -ERRNO.  This was an inadvertant bug
127   introduced when clobber lists changed.
128 - add ppc64pseries and ppc64iseries to exclusivearch
129
130 * Tue Sep 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.100-1
131 - Switch around the tests for _PPC_ and _powerpc64_ so that the ppc64 
132   platforms get the right padding.
133
134 * Wed Jul 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-4
135 - Ok, there was a race in moving the cvs module.  Someone rebuild from
136   the old cvs into fc3.  *sigh*  bumping rev.
137
138 * Wed Jul 14 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-3
139 - Actually provide libaio.so.1.
140
141 * Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-2
142 - Apparently the 0.3.93 patch was not meant for 0.3.96.  Backed it out.
143
144 * Tue Mar 30 2004 Jeff Moyer <jmoyer@redhat.com> - 0.3.99-1
145 - Fix compat calls.
146 - make library .so.1.0.0 and make symlinks properly.
147 - Fix header file for inclusion in c++ code.
148
149 * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-2
150 - bah.  fix version nr in changelog.
151
152 * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.98-1
153 - fix compiler warnings.
154
155 * Thu Feb 26 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-2
156 - make srpm was using rpm to do a build.  changed that to use rpmbuild if
157   it exists, and fallback to rpm if it doesn't.
158
159 * Tue Feb 24 2004 Jeff Moyer <jmoyer@redhat.com> 0.3.97-1
160 - Use libc syscall(2) instead of rolling our own calling mechanism.  This 
161   change is inspired due to a failure to build with newer gcc, since clobber 
162   lists were wrong.
163 - Add -fpic to the CFLAGS for all architectures.  Should address bz #109457.
164 - change a #include from <linux/types.h> to <sys/types.h>.  Fixes a build
165   issue on s390.
166
167 * Wed Jul  7 2003 Bill Nottingham <notting@redhat.com> 0.3.96-3
168 - fix paths on lib64 arches
169
170 * Wed Jun 18 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.96-2
171 - optimization in io_getevents from Arjan van de Ven in 0.3.96-1
172 - deal with ia64 in 0.3.96-2
173
174 * Wed May 28 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.95-1
175 - ppc bugfix from Julie DeWandel
176
177 * Tue May 20 2003 Michael K. Johnson <johnsonm@redhat.com> 0.3.94-1
178 - symbol versioning fix from Ulrich Drepper
179
180 * Mon Jan 27 2003 Benjamin LaHaise <bcrl@redhat.com>
181 - bump to 0.3.93-3 for rebuild.
182
183 * Mon Dec 16 2002 Benjamin LaHaise <bcrl@redhat.com>
184 - libaio 0.3.93 test release
185 - add powerpc support from Gianni Tedesco <gianni@ecsc.co.uk>
186 - add s/390 support from Arnd Bergmann <arnd@bergmann-dalldorf.de>
187
188 * Fri Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
189 - libaio 0.3.92 test release
190 - build on x86-64
191
192 * Thu Sep 12 2002 Benjamin LaHaise <bcrl@redhat.com>
193 - libaio 0.3.91 test release
194 - build on ia64
195 - remove libredhat-kernel from the .spec file
196
197 * Thu Sep  5 2002 Benjamin LaHaise <bcrl@redhat.com>
198 - libaio 0.3.90 test release
199
200 * Mon Apr 29 2002 Benjamin LaHaise <bcrl@redhat.com>
201 - add requires initscripts >= 6.47-1 to get boot time libredhat-kernel 
202   linkage correct.
203 - typo fix
204
205 * Thu Apr 25 2002 Benjamin LaHaise <bcrl@redhat.com>
206 - make /usr/lib/libredhat-kernel.so point to /lib/libredhat-kernel.so.1.0.0
207
208 * Mon Apr 15 2002 Tim Powers <timp@redhat.com>
209 - make the post scriptlet not use /bin/sh
210
211 * Sat Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
212 - add /lib/libredhat-kernel* to %files.
213
214 * Fri Apr 12 2002 Benjamin LaHaise <bcrl@redhat.com>
215 - make the dummy install as /lib/libredhat-kernel.so.1.0.0 so 
216   that ldconfig will link against it if no other is installed.
217
218 * Tue Jan 22 2002 Benjamin LaHaise <bcrl@redhat.com>
219 - add io_getevents
220
221 * Tue Jan 22 2002 Michael K. Johnson <johnsonm@redhat.com>
222 - Make linker happy with /usr/lib symlink for libredhat-kernel.so
223
224 * Mon Jan 21 2002 Michael K. Johnson <johnsonm@redhat.com>
225 - Added stub library
226
227 * Sun Jan 20 2002 Michael K. Johnson <johnsonm@redhat.com>
228 - Initial packaging