369c8d295d607a21a38a2a62f21da074cb785875
[platform/upstream/libXaw.git] / packaging / libXaw.spec
1 Name:           libXaw
2 Version:        1.0.11
3 Release:        1
4 License:        MIT
5 Summary:        X Athena Widget Set
6 Url:            http://www.x.org
7 Group:          Graphics/X Window System
8 Source:         %{name}-%{version}.tar.bz2
9 BuildRequires:  ed
10 BuildRequires:  pkgconfig(x11)
11 BuildRequires:  pkgconfig(xext)
12 BuildRequires:  pkgconfig(xmu)
13 BuildRequires:  pkgconfig(xorg-macros)
14 BuildRequires:  pkgconfig(xpm)
15 BuildRequires:  pkgconfig(xproto)
16 BuildRequires:  pkgconfig(xt)
17
18 %description
19 Xaw is a widget set based on the X Toolkit Intrinsics (Xt) Library.
20
21 %package devel
22 Summary:        Development files for %{name}
23 Group:          Development/Libraries
24 Requires:       %{name} = %{version}
25 Requires:       pkgconfig
26 Requires:       pkgconfig(xmu)
27 Requires:       pkgconfig(xpm)
28 Requires:       pkgconfig(xproto)
29 Requires:       pkgconfig(xt)
30
31 %description devel
32 X.Org X11 libXaw development package
33
34 %prep
35 %setup -q
36
37 %build
38 export CFLAGS="${CFLAGS} %{optflags} -Os"
39 %reconfigure \
40                --disable-xaw8 --disable-static \
41                --disable-xaw6
42 make %{?_smp_mflags}
43
44 %install
45
46 make install DESTDIR=%{buildroot} INSTALL="install -p"
47 rm -f %{buildroot}%{_libdir}/*.la
48
49 %remove_docs
50
51 %post -p /sbin/ldconfig
52 %postun -p /sbin/ldconfig
53
54 %files
55 %defattr(-,root,root,-)
56 %license COPYING
57 %{_libdir}/libXaw.so.7
58 %{_libdir}/libXaw7.so.7
59 %{_libdir}/libXaw7.so.7.0.0
60
61 %files devel
62 %defattr(-,root,root,-)
63 %dir %{_includedir}/X11/Xaw
64 %{_includedir}/X11/Xaw/*.h
65 # FIXME:  Is this C file really supposed to be here?
66 %{_includedir}/X11/Xaw/Template.c
67 %{_libdir}/libXaw.so
68 %{_libdir}/libXaw7.so
69 %{_libdir}/pkgconfig/xaw7.pc