packaging: Disable UBSan build
[platform/upstream/gummiboot.git] / packaging / gummiboot.spec
1 Name:           gummiboot
2 Version:        43
3 Release:        1
4 License:        LGPL-2.1
5 Summary:        EFI Kernel loader
6 Url:            http://cgit.freedesktop.org/gummiboot/
7 Group:          Base/Startup
8 Source0:        http://cgit.freedesktop.org/%{name}/snapshot/%{name}-%{version}.tar.gz
9 Source1001:     gummiboot.manifest
10 BuildRequires:  gnu-efi
11 BuildRequires:  pkgconfig(blkid)
12 ExclusiveArch:  %ix86 x86_64
13
14
15 %description
16 Gummiboot is a simple EFI bootloader.
17
18 %package splash
19 Summary:        Gummiboot default splash image
20 BuildArch:      noarch
21 Requires:       %{name} = %{version}
22
23 %description splash
24 This package contains the Gummiboot default splash image. It's the
25 project logo and maintained in the upstream gummiboot Git tree.
26
27 %prep
28 %setup -q -n %{name}-%{version}
29
30 %build
31 %{?asan:/usr/bin/gcc-unforce-options}
32 %{?ubsan:/usr/bin/gcc-unforce-options}
33 GCC_SEARCH_PATH=$(gcc -print-search-dirs | sed -ne '/install:/s/install: //p')
34 cp %{SOURCE1001} .
35 %reconfigure --with-efi-libdir=/usr/lib --with-efi-ldsdir=/usr/lib
36 %{__make} EFI_CPPFLAGS=-I$GCC_SEARCH_PATH/include
37
38 %install
39 rm -fr %{buildroot}
40 %make_install
41
42 mkdir -p %{buildroot}/%{_datadir}/%{name}
43 cp test/splash.bmp %{buildroot}/%{_datadir}/%{name}
44
45 %files
46 %manifest %{name}.manifest
47 %defattr(-,root,root)
48 %manifest gummiboot.manifest
49 %{_bindir}/gummiboot
50 %ifarch x86_64
51 %{_prefix}/lib/gummiboot/gummibootx64.efi
52 %else
53 %{_prefix}/lib/gummiboot/gummibootia32.efi
54 %endif
55
56 %files splash
57 %{_datadir}/%{name}/splash.bmp