12326a36ab583e5a16d7df2e21729b9eb42d39a2
[platform/upstream/gummiboot.git] / packaging / gummiboot.spec
1 Name:           gummiboot
2 Version:        43
3 Release:        1
4 License:        LGPL-2.1
5 Summary:        EFI Kernel loader
6 Url:            http://cgit.freedesktop.org/gummiboot/
7 Group:          Base/Startup
8 Source0:        http://cgit.freedesktop.org/%{name}/snapshot/%{name}-%{version}.tar.gz
9 Source1001:     gummiboot.manifest
10 BuildRequires:  gnu-efi
11 BuildRequires:  pkgconfig(blkid)
12 ExclusiveArch:  %ix86 x86_64
13
14
15 %description
16 Gummiboot is a simple EFI bootloader.
17
18 %package splash
19 Summary:        Gummiboot default splash image
20 BuildArch:      noarch
21 Requires:       %{name} = %{version}
22
23 %description splash
24 This package contains the Gummiboot default splash image. It's the
25 project logo and maintained in the upstream gummiboot Git tree.
26
27 %prep
28 %setup -q -n %{name}-%{version}
29
30 %build
31 %{?asan:/usr/bin/gcc-unforce-options}
32 GCC_SEARCH_PATH=$(gcc -print-search-dirs | sed -ne '/install:/s/install: //p')
33 cp %{SOURCE1001} .
34 %reconfigure --with-efi-libdir=/usr/lib --with-efi-ldsdir=/usr/lib
35 %{__make} EFI_CPPFLAGS=-I$GCC_SEARCH_PATH/include
36
37 %install
38 rm -fr %{buildroot}
39 %make_install
40
41 mkdir -p %{buildroot}/%{_datadir}/%{name}
42 cp test/splash.bmp %{buildroot}/%{_datadir}/%{name}
43
44 %files
45 %manifest %{name}.manifest
46 %defattr(-,root,root)
47 %manifest gummiboot.manifest
48 %{_bindir}/gummiboot
49 %ifarch x86_64
50 %{_prefix}/lib/gummiboot/gummibootx64.efi
51 %else
52 %{_prefix}/lib/gummiboot/gummibootia32.efi
53 %endif
54
55 %files splash
56 %{_datadir}/%{name}/splash.bmp