b16b1e81006a58a0816de0c4174d95ab4a4d74a7
[platform/upstream/gtest.git] / packaging / gtest.spec
1 Name:       gtest
2 Summary:    Google Test Framework
3 Version:    1.8.0
4 Release:    0
5 License:    BSD-3-Clause
6 Group:      Development/Testing
7 Source0:    %{name}-%{version}.tar.gz
8 Source1001: gtest.manifest
9 BuildRequires: pkgconfig(python)
10 Provides:   libgtest_main.so.0 libgtest.so.0
11
12 %description
13 Libraries for Google's Test Framework for writing C++ Tests
14
15 %package devel
16 Summary:    Devel package for Google Test Framework
17 Group:      Development/Testing
18 Requires:   %{name} = %{version}-%{release}
19
20 %description devel
21 This is the development package containing the gtest library
22
23 %prep
24 %setup -q
25 cp %{SOURCE1001} .
26
27 %build
28 %configure --prefix=/usr
29 make
30
31 %install
32 make DESTDIR=$RPM_BUILD_ROOT install
33
34 %clean
35 [ ${RPM_BUILD_ROOT} != "/" ] && rm -rf ${RPM_BUILD_ROOT}
36
37 %post
38 /sbin/ldconfig
39
40 %postun
41 /sbin/ldconfig
42
43 %files
44 %manifest %{name}.manifest
45 %defattr(-,root,root)
46 %{_libdir}/libgtest_main.so.*
47 %{_libdir}/libgtest.so.*
48 %license COPYING
49
50 %files devel
51 %manifest %{name}.manifest
52 /usr/include/gtest/*.h
53 /usr/include/gtest/internal/*.h
54 %{_libdir}/libgtest_main.so
55 %{_libdir}/libgtest.so
56 %{_libdir}/libgtest_main.la
57 %{_libdir}/libgtest_main.a
58 %{_libdir}/libgtest.la
59 %{_libdir}/libgtest.a
60 /usr/share/aclocal/gtest.m4
61
62 %changelog