Bump to 1.14.0
[platform/upstream/gtest.git] / packaging / gtest.spec
1 Name:       gtest
2 Summary:    Google C++ Testing Framework
3 Version:    1.14.0
4 Release:    0
5
6 # ==========================================================
7 License:    BSD-3-Clause
8 # ==========================================================
9
10 Group:      Definition/Libraries/C and C++
11 Source0:    %{name}-%{version}.tar.gz
12 Source1001: %{name}.manifest
13
14 # ==========================================================
15 # BuildRequires
16 # specifies build-time dependencies for the package
17 # ==========================================================
18 BuildRequires:  cmake
19 Provides:   libgtest_main.so.0 libgtest.so.0
20 Provides:   libgmock_main.so.0 libgmock.so.0
21
22 %description
23 Google's framework for writing C++ tests on a variety of platforms (Linux, Mac
24 OS X, Windows, Cygwin, Windows CE, and Symbian). Based on the xUnit
25 architecture. Supports automatic test discovery, a rich set of assertions,
26 user-defined assertions, death tests, fatal and non-fatal failures, value- and
27 type-parameterized tests, various options for running the tests, and XML test
28 report generation.
29
30
31 %package devel
32 Summary:    Google C++ Testing Framework
33 Requires:   %{name} = %{version}
34
35 %description devel
36 Google C++ Testing Framework
37
38
39 %prep
40 %setup -q
41 cp %{SOURCE1001} .
42
43 # ==========================================================
44 # build section
45 # how to actually build the software we are packaging
46 # ==========================================================
47 %build
48 mkdir -p build
49 pushd build
50 %{cmake} ..
51 %{__make} %{?_smp_mflags}
52 popd
53
54
55 # ==========================================================
56 # install section
57 # how to actually build the software we are packaging
58 # ==========================================================
59 %install
60 pushd build
61 %{make_install}
62 popd
63
64 rm -f %{buildroot}/%{_includedir}/gmock/internal/custom/README.md
65 rm -f %{buildroot}/%{_includedir}/gtest/internal/custom/README.md
66
67 %clean
68
69 %post -p /sbin/ldconfig
70
71 %postun -p /sbin/ldconfig
72
73 # ==========================================================
74 # files section
75 # The list of files that will be installed in the end
76 # user’s system.
77 # ==========================================================
78 %files
79 %manifest %{name}.manifest
80 %license LICENSE
81 %{_libdir}/*.so.*
82 %{_libdir}/*.so
83
84 %files devel
85 %manifest %{name}.manifest
86 %license LICENSE
87 %{_libdir}/pkgconfig/gtest_main.pc
88 %{_libdir}/pkgconfig/gtest.pc
89 %{_libdir}/pkgconfig/gmock_main.pc
90 %{_libdir}/pkgconfig/gmock.pc
91 %{_includedir}/gmock/*.h
92 %{_includedir}/gmock/internal/*.h
93 %{_includedir}/gmock/internal/custom/*.h
94 %{_includedir}/gtest/*.h
95 %{_includedir}/gtest/internal/*.h
96 %{_includedir}/gtest/internal/custom/*.h
97 %{_libdir}/cmake/GTest/*.cmake