Merge branch 'move_subdir_omx' into tizen_gst_1.19.2_mono
[platform/upstream/gstreamer.git] / subprojects / gst-omx / meson.build
index d37fc7b..20960ce 100644 (file)
@@ -223,12 +223,21 @@ elif omx_target == 'tizonia'
   tizil_includedir = tizil_dep.get_pkgconfig_variable('includedir')
   gst_omx_args += ['-I' + tizil_includedir + '/tizonia']
   omx_inc = []
+elif omx_target == 'exynos64'
+  cdata.set('USE_OMX_TARGET_EXYNOS64', 1)
+elif omx_target == 'exynos'
+  cdata.set('USE_OMX_TARGET_EXYNOS', 1)
 else
   error ('Unsupported omx target specified. Use the -Dtarget option')
 endif
 
 message ('OMX target: ' + omx_target)
 
+# Tizen options
+tbm_dep = dependency('libtbm', required : true)
+have_omx_vp9 = get_option('vp9')
+cdata.set ('HAVE_VP9', have_omx_vp9)
+
 extra_video_headers = ''
 # Check for optional OpenMAX extension headers