Merge remote-tracking branch 'upstream/master' into tizen
[platform/upstream/gstreamer.git] / packaging / gstreamer.spec
index 5a126f9..39e489c 100644 (file)
@@ -1,14 +1,15 @@
 %define gst_branch 1.0
 
 Name:           gstreamer
-Version:        1.16.2
-Release:        5
+Version:        1.19.2
+Release:        0
 Summary:        Streaming-Media Framework Runtime
 License:        LGPL-2.0+
 Group:          Multimedia/Framework
 Url:            http://gstreamer.freedesktop.org/
 Source0:        http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-%{version}.tar.xz
 Source100:      common.tar.gz
+BuildRequires:  meson >= 0.48.0
 BuildRequires:  bison
 BuildRequires:  gettext-tools
 BuildRequires:  check-devel
@@ -61,10 +62,6 @@ to develop applications that require these.
 %setup -q -T -D -a 100
 
 %build
-# FIXME: GTKDOC_CFLAGS, GST_OBJ_CFLAGS:
-# Silently ignored compilation of uninstalled gtk-doc scanners without RPM_OPT_FLAGS.
-export V=1
-NOCONFIGURE=1 ./autogen.sh
 export CFLAGS="%{optflags} \
        -DTIZEN_FEATURE_QUEUE2_MODIFICATION\
        -DTIZEN_FEATURE_FILESINK_MODIFICATION\
@@ -87,25 +84,18 @@ export CFLAGS="%{optflags} \
        -Wl,-z,relro\
        -D_FORTIFY_SOURCE=2"
 
-%configure\
-%if %{with introspection}
-        --enable-introspection\
-%endif
-        --disable-static\
-        --disable-docbook\
-        --disable-gtk-doc\
-        --enable-dlog\
-%if "%{tizen_profile_name}" == "tv"
-        --enable-tv-profile\
-%endif
-        --disable-examples\
-        --disable-tests\
-        --with-ptp-helper-permissions=none
+%meson --auto-feature=auto \
+  -D bash-completion=disabled \
+  -D check=disabled \
+  -D examples=disabled \
+  -D tests=disabled \
+  -D doc=disabled \
+  -D ptp-helper-permissions=none
 
-make %{?_smp_mflags}
+%meson_build
 
 %install
-%make_install
+%meson_install
 mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
 mkdir -p %{buildroot}%{_docdir}/%{name}
 %find_lang %{name}-%{gst_branch}
@@ -135,7 +125,7 @@ mkdir -p %{buildroot}%{_datadir}/gstreamer-%{gst_branch}/presets
 %{_libdir}/*.so.*
 %{_libdir}/girepository-1.0/Gst-1.0.typelib
 %{_libdir}/girepository-1.0/GstBase-1.0.typelib
-%{_libdir}/girepository-1.0/GstCheck-1.0.typelib
+#%{_libdir}/girepository-1.0/GstCheck-1.0.typelib
 %{_libdir}/girepository-1.0/GstController-1.0.typelib
 %{_libdir}/girepository-1.0/GstNet-1.0.typelib
 %{_datadir}/gdb/auto-load/usr/%{_lib}/libgstreamer*-gdb.py